0

On a fresh install and updated Linux Mint 17 XFCE, the system cannot maintain an internet connection through wifi, and is unable to connect at all through ethernet. Wifi will work somewhat slowly for a few minutes and then stop internet access. It usually maintains a connection to the router, but cannot load anything.

I have gone through installing different types of drivers for my specific usb wifi adapter with no connection improvement. These were from the manufacturer (Netis) website, the Realtek website, and other modified drivers from the community that should circumvent what appears to be a driver problem.

I know that this issue has been seen before from checking many forums and documents online. I've spent a few days trying to sort this out to no avail. Would anyone be able to help resolve my specific case?

I have been able to connect to another computer through ethernet, so it appears that the drivers for that hardware is working to a degree.

My system specifications are below, let me know if I should post up any terminal output that would be useful:

Asus Z97-A motherboard; Intel Pentium G3258 CPU

Netis WF2111 (rtl8192cu driver); Also tried older Netgear WG111v2, resulted in same connection problems. Arris NVG859 Router (ISP: AT&T)

Intel I218-V Ethernet (e1000e driver, I think this is the correct one but cannot verify the version)

iwconfig output:

wlan0     IEEE 802.11bgn  ESSID:"VVVVVVVVVV"  
      Mode:Managed  Frequency:2.437 GHz  Access Point: 94:62:69:25:B8:20   
      Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
      Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
      Power Management:off
      Link Quality=70/70  Signal level=-38 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0
  • Sorry to dig this up but I'm having the exact same issue with my wifi, dropping connection and about 80% a lower than anything else I have connected to my router via wireless. Any fix? Kernel update didn't fix it – Steven Yates Sep 16 '15 at 20:58
  • I don't think there was a fix for this problem with the hardware I was using. I purchased a different wifi router (Panda Wireless PAU06 300Mbps N USB Adapter) which has worked extremely well straight out of the box. – venture Jun 19 '16 at 23:54
1

I recently had this same issue with Mint 17.1 Cinnamon. I was able to fix the issue with a kernel update. My old kernel was 3.13.24 and since updating to 3.16.30, my internet connection is back up to 100% and no longer taking forever to load a page or dropping the connection. Prior to the update, my internet connection was around 83% and that was right beside my router and no other devices connected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.