I've installed KaliLinux on my VirtualBox. Then I faced a problem: I couldn't connect to the internet. I was going through many tutorials, that's what I did: -Went to Settings->Network, enabled network adapter, changed it to "Bridged Adapter" and made it "AllowAll". Didn't help. Airmon-ng shows empty result set. Next thing is that "ifconfig"/"iwconfig" shows Eth0 for me, while ppl showing tutorials had Wlan0 there. On my notebook I'm using wifi, no cables or anything. Furthermore, on Devices->UsbDevices, I have my mouse device detected + "Unknown Device" clicking on which causes an error.


I'd forget: I also change the boolean in NetworkManager.conf file to true.

2 Answers 2


I found the instructions in the following link and it worked for me, since I already had the setup described by eyeyoung100 :

Can't access internet in kali virtualbox

Essentially the commands that got me online were

sudo ifconfig eth0 up 
sudo dhclient eth0

Although in my case it was eth1, since eth0 was already connected to the host-only network.


Settings > Network > NAT, Check Cable Connected.

Advanced > Adapter Type > 82540EM > Promiscuous Mode > Deny

In the VM, enable dhcpcd

VirtualBox Network Settings - Windows Host

  • Can't switch to "Deny" when NAT is chosen
    – Pijotrek
    Commented Sep 4, 2014 at 19:47
  • @user3447603 See Screenshot, Deny Should be the default setting, and is grayed out.
    – eyoung100
    Commented Sep 4, 2014 at 19:55
  • Well, I switched to AllowAll trying all the stuff around. So I went for Bridged again, switched to Deny, then changed to NAT again. Now it's grayed with Deny, haha. I finally have a connection, thank you. Could you suggest me how could I obtain a different IP? Like this VM was a separate machine
    – Pijotrek
    Commented Sep 4, 2014 at 19:58
  • This Setting should give you an IP, but if you want a different one, edit the configs in the Virtual Machine to the settings you desire.
    – eyoung100
    Commented Sep 4, 2014 at 20:19
  • The IP i'm getting is some internal one. I mean I can't even use a tool like Wireshark to get traffic from host notebook.
    – Pijotrek
    Commented Sep 4, 2014 at 20:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .