1

I am trying to check out code on a Unix box in the Z shell. When I run the following command

svn checkout https://svn.example.net/svn/trunk/source build I get the following error message:

svn: SSL is not supported

The error message is in no way informative so I'd like to see if anyone has had a similar problem and even better if they have a solution. Thanks

  • Is SSL supported if you switch to BASH?, i.e do you get the same error returned in BASH? – eyoung100 Sep 4 '14 at 15:35
1

If you run svn --version, you'll see that "handles 'https' scheme" is not listed. You need to recompile Subversion with SSL support (with the serf library, itself built with SSL support).

  • Adding to this, neon can also be a possible offender. See this blog – eyoung100 Sep 4 '14 at 15:40
  • @ECarterYoung This is old. One can build Subversion with either neon (for Subversion < 1.8) or serf. – vinc17 Sep 4 '14 at 15:44
  • @ECarterYoung I've edited my comment: neon is no longer supported. – vinc17 Sep 4 '14 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.