3

I'm having a massive amount of trouble installing gentoo with systemd; this is a fresh install and not an upgrade.

Steps (after partitions etc.. are setup):

  1. Unpack AMD64 stage3 and emerge-webrsync and then emerge --sync for good measure

  2. Eselect profile gnome/systemd

  3. emerge --update --deep --with-bdeps=y --newuse @world

  4. emerge gentoo sources; config and make the kernel -the gentoo systemd option is enabled as is openrc

  5. Install the kernel

  6. install mdm and lvm (I'm running a raid0 as root)

  7. install gentoo-next and genkernel --install --no-ramdisk-modules -mdadm -lvm --udev initramfs (this is as suggested by the systemd and raid install wikis)

  8. emerge grub2 and install it with init set to systemd

  9. install some utils (e.g dhcpcd)

When I boot into the system i get nothing but a bunch of trouble - never actually having the system boot in full.

Errors (in no particular order as I had to write them by hand):

Failed to start trigger flushing of journal to persistent storage
Systemd-journal-flush service entered failed state
Systemd-journald.service.watchdog.timeout
Systemd-journal-flush.service exited, code=exited status=1/Failyre

A start job is running for udev Kernel Device Manager service...
Systemd-udevd.service.start operation timed out

Failed to start udev kernel device manager

It just sits there looping for the udev KDM startup always failing

if i hit control alt delete (or indeed type shutdown -h now from within the chrooted environment) i get the following:

Failed to start reboot
Dependency for reboot failed

systemd-reboot service main process exited..

shutdown -h now

shutdown: /dev/initctl: No such file or directory
init: /dev/initctl: No such file or directory

I've been googling for a couple days now but couldn't find anything (though it is possible I'm blind). Journactl (when i chroot into the setup) says No Journal Files Were Found. I'm at a complete loss at this point. If anyone has any suggestions i would greatly appreciate them!

  • Hard to determine from this short description, but I would start from removing openrc from kernel config if you don't want to use it. systemd and openrc can potentially conflict each other. Secondly please be sure that you pass systemd path to kernel at grub level, something like: kernel [...] init=/usr/lib/systemd/systemd – jimmij Sep 3 '14 at 20:43
  • Will recompile and shout loudly if it works. Have tried both init=/usr/lib/systemd/systemd and real_init=... with no success. – Michael Chase Sep 3 '14 at 20:56
  • I recompiled and booted; it actually went to the login but it wouldnt accept my credentials. Back to debian reset the password, boot again - same issues. If there is any additional information relevant to the problem that is missing please let me know. – Michael Chase Sep 3 '14 at 21:19
  • Is there any specific message? Any warning/error during boot process? Have you tried boot in single user mode (option S in kernel)? – jimmij Sep 3 '14 at 21:25
  • There are no other error/warning messages beyond the ones I posted. Single user mode made no difference. – Michael Chase Sep 3 '14 at 21:55
4

I've done this already:

  1. Complete the Handbook from Chapter 1 to the End of Chapter 6.
  2. On Another machine, go here to the Gentoo Systemd Wiki
  3. Combine Handbook Chapter 7 with Wiki Section 1
  4. Complete Handbook Chapter 7, by compiling the kernel. There is no need to remove openrc, as you need a fallback if something fails, and using a systemd profile assumes this. See my comment in your question to Casey regarding genkernel-next if you want to use genkernel-next. Please note genkernel does NOT work.
  5. Complete Wiki Section 2 - Installation, taking note of the Circular dependency.
  6. Combine Handbook Chapter 8 with Wiki Section 4, notice you have skipped Wiki Section 3.
  7. Complete Handbook Chapter 9, using the service names in Wiki Section 5.6. Be sure to enable them, so that they start on reboot into live system.
  8. Complete Handbook Chapter 10, and add the appropriate configuration from Wiki Section 3. You will have exited the chroot, and rebooted here.
  9. If you use dhcp enable and start the dhcpcd service. If you need to configure dhcp, i.e. static ip address, nameservers etc, enable the networkmanager USE Flag, and read the NetworkManager Wiki. Use emerge --update --deep --with-bdeps=y --newuse @world to catch the new USE Flag.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.