10

I recently got a Thinkpad T440s with Windows 8.1 for my job, and since most of my work is done under Linux I am going to install Ubuntu on it, so that I can dual boot. The problem is that it won't boot from USB. In the BIOS, the Boot Priority Order only has the Windows Boot Manager and LAN, with USB devices appearing under "Excluded from boot priority order" lower down.

After preparing a USB flash drive as a Ubuntu installer, I thought I can get the computer to boot from USB at least once by going through the PC Settings window, then Update and Recovery -> Recovery -> Advanced Start Up -> Use a Device and picking one of the USB devices, but the computer just ignores the flash drive and boots straight into Windows.

On older computers I just use GRUB to pick what operating system to boot into, but with this computer I'm not sure how to best configure the start up - is Windows Boot Manager going to interfere?

I tried to search on Google but nothing I could find was really of help. The techs here won't help or support me, although installing Linux is allowed - and even necessary, in my case.

  • 1
    Oh look, UEFI problems. You might want to swap one of your tags (lenovo or thinkpad) for it. – SailorCire Sep 3 '14 at 16:41
  • Ok, good idea, I swapped in the UEFI tag. – Btz Sep 3 '14 at 16:47
6

Change the BIOS from UEFI to legacy. When I did that, the USB appeared in the boot menu when restarting my computer.

4

You probably just need to disable Secure Boot, so the linux installer is allowed to boot.

You can check whether this is enable by running this in a Windows terminal (e.g. powershell):

Confirm-SecureBootUEFI

If you have it Enabled, go to the power off options and while holding the Shift key, click on Restart. Then select 'Troubleshoot', 'UEFI Firmware Settings'. You can then choose to 'Disable Secure Boot'.

A full guide on 'Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (UEFI Supported)' can be found here.

  • Doing that brings me in the BIOS config screen. In its Main section, it says that the UEFI Secure Boot is off. Despite that, no USB device appears using F12. – Btz Sep 3 '14 at 16:37
  • 1
    By the way, the guide you link to says there is no need to disable Secure Boot, but does that hold? In any case, it seems like it's already disabled. – Btz Sep 3 '14 at 16:48
  • Are you sure the USB installer is setup correctly? For example, when viewing under windows, does it show mutiple files (like this). How did you create the USB? (N.B. there is a guide here that recommends using Pen drive linux) – Wilf Sep 3 '14 at 17:24
  • I used Startup Disk Creator on a Ubuntu 14.04 desktop machine, which by the way boots the USB installer with no problem. – Btz Sep 4 '14 at 8:56
  • @Btz running without secure boot can work, just on most linux OSs at the mo it may break some drivers and hibernation – Wilf Sep 25 '18 at 23:21
3

I have the same laptop and do have Ubuntu installed on it.

All I had to do was navigate to the "Restart" area in BIOS and disable OS optimised defaults. Navigate to the "Startup" area and ensure that the F12 boot option is enabled. Exit saving changes. Check if you have the authority to do this.

  • The F12 boot option is enabled. The USB flash drive won't appear in the Boot menu. USB devices show up in the "Excluded from boot priority order" list of Boot->Startup in the BIOS. – Btz Sep 3 '14 at 16:28
  • Ok. What happens when you select the USB devices under "Excluded from boot priority order" and press Shift + 1 ? It should move to the Boot Priority Order List. – vikkp Sep 3 '14 at 16:49
  • Nothing. Startup->Boot just gives me these two lists (the one for boot priority and the one for excluded devices) and I can scroll them but not, apparently edit them. +/- Enter, F9, numeric keys, left/right cursors won't work. – Btz Sep 3 '14 at 16:54
1

I finally got the tech people to admit they password-locked the BIOS. After they changed the password, I was able to alter the boot sequence and start the installation of Linux.

protected by Community Mar 12 '16 at 13:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.