I've been trying to establish an RDP conexion with a Windows 7 machine from Linux with sound AND microphone redirection, I have tried rdesktop, remmina and freerdp with no use.

Finally, with freerdp I have finally managed to get sound and microphone redirection but from different sessions. I mean

xfreerdp -u user -d domain -p password --plugin drdynvc --data audin -- server

Allows me to send the microphone to the remote machine.

xfreerdp -u user -d domain -p password --plugin rdpsnd --data pulse -- server

Allows me to get the sound from the remote machine, but I can't manage to get both within the same session.

Any ideas?


I have finally found the solution. Looking for an answer for the remmina client, a guy had xfreerdp working and not remmina and he posted his xfreerdp command here. The thing was that when I was launching the command with the two plugins (drdynvc and rdpsnd) I was also passing two data strings audin and pulse and that doesn't work. The solutions is passing two plugins with just audin as data:

xfreerdp -u user -d domain -p password --plugin drdynvc --plugin rdpsnd --data audin -- server

  • This does not work for me on Arch Linux, I get an error about /usr/lib/freerdp/... not existing.
    – BitShift
    Aug 29 at 15:05

This seems to have been much improved in more recent versions of freerdp.

Now, just using the /sound /microphone:sys:alsa options seem to work fine.

Once https://github.com/FreeRDP/FreeRDP/pull/3597 is merged, it'll be just /sound /microphone again.

https://github.com/FreeRDP/FreeRDP/wiki/PreBuilds contains nightly builds which worked much better than my distribution's outdated packages.

  • Is there any released version where this works, or do I still need a nightly build?
    – gerrit
    Jun 23 '17 at 15:00
  • I'm using this, and sound works, but microphone does not. See this question.
    – gerrit
    Jun 23 '17 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.