1

Whenever I try and install OpenVPN on My Debian x86 Minimal VPS I get that error. Here is the full code if that helps:

root@fadvps:/# sudo apt-get install openvpn
Reading package lists... Done
Building dependency tree       
Reading state information... Done
openvpn is already the newest version.
The following packages were automatically installed and are no longer required:
  gconf-service gconf2 gconf2-common libasound2-dev libavahi-client-dev libavahi-common-dev libcaca-dev libdbus-1-dev libdbus-glib-1-2
  libdirectfb-extra libelfg0 libevent-2.0-5 libgconf-2-4 libgd2-xpm libglib2.0-bin libglib2.0-dev libicu48 libjbig-dev libjpeg8-dev libnatpmp1
  libpcre3-dev libpcrecpp0 libpng12-dev libpthread-stubs0 libpthread-stubs0-dev libpulse-dev libpulse-mainloop-glib0 libslang2-dev
  libtiff4-dev libtiffxx0c2 libts-dev libva-egl1 libva-glx1 libva-tpi1 libva-x11-1 libvdpau1 libwebp-dev libx11-doc libxau-dev libxcb1-dev
  libxdmcp-dev postgresql-common ssl-cert transmission-common transmission-gtk x11proto-core-dev x11proto-fixes-dev x11proto-input-dev
  x11proto-kb-dev x11proto-xext-dev xorg-sgml-doctools xtrans-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 368 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up fuse (2.9.3-15) ...
Creating fuse device...
/run/udev or .udevdb or .udev presence implies active udev.  Aborting MAKEDEV invocation.
chmod: cannot access `/dev/fuse': No such file or directory
dpkg: error processing fuse (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 fuse
E: Sub-process /usr/bin/dpkg returned an error code (1)

What's causing these errors?

3 Answers 3

2

Your VPS is probably being run inside a virtualized container which shares a kernel with the host and which is not allowed to use FUSE; that would mean that the fuse module is not present which again is why udev cannot create /dev/fuse. Have a look at the output of modinfo fuse or even lsmod. I'd expect no modules to exist since they are managed by the host.

So if you actually needed FUSE, you'd have to (ask your provider to) enable it for your container.

However, I wouldn't know what OpenVPN used FUSE for, so I'd expect openvpn to have been installed correctly nevertheless.

To get rid of the error (which will pop up with every package), just apt-get remove fuse(whatever caused it to be installed as a dependency will not work until it has been enabled).

Hth, dtk

0

The first bunch of message are indicating you have not installed any locales. This is just a warning you should be able to fix with apt-get install locales.

The actual error is later after "Creating fuse device". To populate the /dev/ directory there are two ways. Modern systems use udev to dynamically add devices as they come and go, older system used to use MAKEDEV to statically create a whole bunch of devices.

In your case MAKEDEV was called and detected traces of udev and therefore did not create any device files.

The following commands expect some device files which are not there.

To solve this check what happend to your udev daemon. Maybe reinstalling udev might be good. Maybe just rebooting you box might be enough.

If udev if indeed running, it did not create /dev/fuse for some reason. Maybe you need to manually load the correct kernel module using modprobe fuse.

-1

Create the directory /dev/fuse

mkdir /dev/fuse

Once you run that command try the install again

2
  • What makes you believe that /dev/fuse is supposed to be a directory? Jul 16, 2016 at 23:51
  • Creating fuse device... /run/udev or .udevdb or .udev presence implies active udev. Aborting MAKEDEV invocation. chmod: cannot access `/dev/fuse': No such file or directory dpkg: error processing fuse (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: fuse E: Sub-process /usr/bin/dpkg returned an error code (1) I ran in to this error and that fixed it for me
    – Devin
    Aug 28, 2016 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.