0

I cannot start the Wifi Hotspot on Fedora 20 Mate Desktop Environment from NetworkManager. But when i log off and login to GNOME i am able to start it. I read some stuffs about hostapd but couldn't figure out. But as i can start the Hotspot on Gnome i guess my wifi interface definitely supports AP mode (read somewhere that it is required.). Now what am i missing here.?

I installed hostapd which i think wasn't on my system and tried to change some configuration in hostapd.conf but could never start the service.

This is how my conf file looks like :

rsn_pairwise=CCMP
interface=wlp3s0
driver=nl80211
ssid=xxxxxx
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=3
wpa_passphrase=xxxxxx
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP

Error when i try to start the service.

Sep 02 19:51:53 kingsTP hostapd[16470]: Configuration file: /etc/hostapd/hostapd.conf
Sep 02 19:51:53 kingsTP hostapd[16470]: nl80211: Failed to set interface wlp3s0 into AP mode
Sep 02 19:51:53 kingsTP hostapd[16470]: nl80211 driver initialization failed.
Sep 02 19:51:53 kingsTP systemd[1]: hostapd.service: control process exited, code=exited status=1
Sep 02 19:51:53 kingsTP systemd[1]: Failed to start Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator.

But how come Gnome Network manager is able to start the hostpot even without hostapd. What is difference between this two environments. What exactly is required for running a hostspot and how to make it work on MATE.

2
  • I also tried to create wifi network with Infrastructure mode, but it didn't work.
    – bluefoggy
    Sep 2, 2014 at 14:31
  • in my experience (after search a lots web pages), you need to turn wifi off in NetworkManager, then execute rfkill unblock wifi, then start hostapd. The reason is wpa_supplicant is fighting with hostapd for seizing the wireless device. >> nl80211: Failed to set interface wlp3s0 into AP mod Mar 10, 2015 at 14:19

1 Answer 1

1

This is not at all about desktop environments. You can configure NetworkManager and use it from any desktop environments to provide the wifi hotspot for you and it in turn uses the hotspot support in wpa_supplicant. It doesn't use hostpad at all. I can't tell you why hostapd doesn't work for you but this should get you running.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .