0

I am having a problem with mounting an internal SSD. For some reason The mounting point is chosen as /media/user/Data instead of, as specified in /etc/fstab, /mnt/Data. The according line in /etc/fstab goes as follows:

UUID="064ced5e-19c1-43d1-876f-3de0c115b65e"     /mnt/Data       ext4    users,noauto,exec,rw,async,dev  0       0

I am using Ubuntu 14.04 LTS 64bit.

(edit:)

Here goes the complete fstab file:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc2 during installation
UUID=9cf86df3-3d02-45d7-8078-d6ff5fc83ea6 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=5AC7-594F  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sdc5 during installation
UUID=5460f609-5245-417a-833a-271c533db97a none            swap    sw              0       0

UUID="064ced5e-19c1-43d1-876f-3de0c115b65e"     /mnt/Data      ext4    users,noauto,exec,rw,async,dev  0       0
  • Are you sure there is nothing else in your /etc/fstab that matches that partition on the SSD? Please dobule-check. The most likely explanation would seem to be an additional fstab entry, perhaps using some other type of device identifier. – a CVn Sep 2 '14 at 11:14
  • I am fairly certain that there is nothing else. The partition is /dev/sdb1. There are other partitions that I am mounting, yet they are on ̀dev/sdc. I added the complete file to my question. – David Wright Sep 2 '14 at 11:23
  • 1
    Um... the two don't match. – a CVn Sep 2 '14 at 11:27
  • well silly me, I'm sorry I changed it because for example my VM needs it as a shared drive, which is annoying to change all the time. Also I might have to add that sometimes it does actually mount to mnt/Data when it is specified to that mounting point. – David Wright Sep 2 '14 at 11:30
  • It seems that it indeed was the noauto setting that messed it all up. Although when setting it to auto the device was not able to be mounted at all. When completely left out, however, it seems like it works. I rebooted the computer twice, both times the device was mounted correctly at startup. – David Wright Sep 2 '14 at 12:04
0

Given the simplicity of the /etc/fstab parser I would expect, removing the quotes around the UUID in the affected entry might help that is, use

UUID=064ced5e-19c1-43d1-876f-3de0c115b65e    /mnt/Data    ...

instead of

UUID="064ced5e-19c1-43d1-876f-3de0c115b65e"  /mnt/Data    ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.