1

After I had completed creating applications for my BB white (running ubuntu), I created a backup of the SD card using->

sudo dd if=/dev/disk2 of=/Volumes/BONE/bone_custom.img

Recently, I tried to burn this image onto a new SD card, using->

sudo dd if=/Volumes/BONE/bone_custom.img of=/dev/disk2 bs=1m

Now, I see that the rootfs is mounted RO. I have made no change to uboot or fstab. Why is this? I tried to remount (and force remount), but I get "mount: cannot remount block device /dev/mmc*** read-write, is write-protected".

How can I solve this?

  • Does the SD card have this tiny hardware switch that protects it from being overwritten? – Jan Sep 1 '14 at 7:11
  • Its a micro sdcard with no lock. – user3490458 Sep 1 '14 at 7:13
  • Can you include the output of the sudo fdisk -l /dev/disk2? – slm Sep 1 '14 at 7:20
  • See a dmesg output, maybe there is some warning about that. I suspect your data wasn't written out entirely and there is a filesystem failure. In this case, a filesystem check will help. – peterh Sep 1 '14 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.