5

I am a visually impaired Computer Science student, and use a special USB camera to zoom in on the board/projector during lectures. The camera only officially supports Windows, and I've been using it for about 2 years. I really enjoy using Linux though, and this one aspect is really preventing me from switching completely (I have a dual boot setup currently with Ubuntu 14.04, and have to reboot for most lectures). I tried setting it up with VirtualBox with a Windows guest, and while the camera drivers and software install fine, the image is just black. I would love to be able to find some method of using it without rebooting, whether that be somehow getting the virtual machine to work, using another camera driver to interface with it as a webcam type device, or writing a new driver.

Does anyone have any suggestions on how to get this to work?

The camera is a SmartView Graduate by HumanWare. I believe it's discontinued now, but here is the support page (with a link to the Windows software:
http://support.humanware.com/en-usa/support/smartview_graduate_support

P.S. Sorry if this is not quite in the scope of Unix/Linux, but I felt that it would be in the case that I'd need to write a driver.

I can also provide a .pcat file to load into Wireshark if it's helpful. I tried looking at the packets but really had no clue what to do with them.

EDIT: I've uploaded the output of lsusb for the camera to pastebin at http://pastebin.com/8dieAAuk Also, here's the output of dmesg:

[  720.831143] usb 2-1.1: new high-speed USB device number 7 using ehci-pci
[  720.930297] usb 2-1.1: New USB device found, idVendor=0b06, idProduct=a513
[  720.930309] usb 2-1.1: New USB device strings: Mfr=0, Product=1, SerialNumber=2
[  720.930316] usb 2-1.1: Product: \xffffffcc\xffffff8c\xffffff8cSV Graduat
  • 1
    What is the output of lsusb? And does a device show up in /dev (/dev/video0 or something to that effect)? – SailorCire Aug 31 '14 at 0:46
  • I updated my original post with the lsusb and dmesg output. It doesn't show up as a video device anywhere (the only two are video0 and video1, which are my internal and external webcams). – Lee Aug 31 '14 at 16:15
  • Have you tried using Linux in a virtual machine on Windows host? – pqnet Aug 31 '14 at 17:59
  • have you tried VMWarePlayer? Have you tried Wine (from WineHQ? if you want to use ubuntu, there is an easy updated ppa for that) @pqnet he seems to love linux now :) – Aquarius Power Aug 31 '14 at 23:12
  • I just tried VMWare Player and it almost worked. Instead of being a black image, it flickered (but not the camera image, just white). – Lee Sep 1 '14 at 3:35
1

Being physically disabled, I understand how you feel. As such, I'm posting the info I find on your device:

VendorID = 0b06 = Athena / Advantage x7500 / Dopod U1000 / T-Mobile AMEO
ProductID = a513 = ??

a513 doesn't exist in any USB Database I could find, but I did find this post over at Reddit. I tend to agree that buying a newer supported product would solve the problem...

I found this list at the American Federation for the Blind

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.