1

I wanted to try out the GNU usb install that was released with Guix 0.7. The problem is that when I try to boot from the USB, it freezes, with the word GRUB and a flashing type line. I followed the instructions. First I downloaded the compressed file from wget http://alpha.gnu.org/gnu/guix/gnu-usb-install-0.7.x86_64-linux.xz, then I extracted it xz gnu-usb-install-0.7.x86_64-linux.xz, then I dd it onto my 64GB USB flash drive, which I formatted to FAT32 and added the boot flag prior to dd'ing it, as so sudo dd if=gnu-usb-install-0.7.x86_64-linux of=/dev/sdb1. And as I said before, when I go on the boot menu and choose to boot from the flash drive, it just shows GRUB _, and everytime I press a key it beeps.

  • on some uefi machines grub video hacks fail miserably and you wind up with a black screen or frozen framebuffer for some time. if the booting kernel does not properly handle GOP video init it will remain that way, though the OS actually does load. in other cases you get the grub rescue prompt and can do something with it. I'm not sure which problem - if either - you have. I can say that if you are formatting a disk then dding a file over it you are likely wasting your time with one or the other operation. – mikeserv Aug 30 '14 at 20:00
  • I tried to tboot the USB on 2 machines, one which used to be a Vista machine with AMD Graphics and ATI video card, I'm not sure about GNU support for that. So the latter problem might a good explanation for why it didn't work on that computer. But on the other one, which is a more recent i7 3rd Gen with GTX nvidia graphics card, should have worked becuase there is very good support for intel graphics by default and nouveau is pretty ok. There was UEFI on the machine, but I disabled it. And if formatting then dd'ing wastes time, it shouldn't make a problem. – toxemicsquire Aug 30 '14 at 20:09
  • you cannot disable uefi. it is the firmware. often you can enable the compatibility support module - but it only adds another layer of complexity. doing so does not necessarily mean the graphics module will support it. and yes format + dd shouldn't make a problem - I think. It is hard to know given the small level of detail you have related. – mikeserv Aug 30 '14 at 20:12
  • It doesn't say that in my BIOS. It gives me the option of disabling UEFI. – toxemicsquire Aug 30 '14 at 20:15
  • you don't have a bios. you have uefi. the option names don't mean much - they just mostly say what little they think they have to. uefi is a type of firmware. bios is another, older type. uefi firmwares often include compatibility support modules - which are legacy modes or whatever and are basically bios emulation layers - so that they may provide backwards-compatible support with bios dependent bootloaders/oses. – mikeserv Aug 30 '14 at 20:17
2

Use /dev/sdb instead of /dev/sdb1 while using dd solved the problem for me.

sudo dd bs=32M if=gnu-usb-install-0.7.x86_64-linux of=/dev/sdb
  • @nwildner it looks like it is a plausible answer, even if it's very short. – roaima Jun 6 '17 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.