1

On Linux within bash the Pseudo Terminal window (terminator) as well as the Terminal itself "freezes" when trying to use autocomplete (TAB) as well as after getting an error message using gzip and tar.

So far this only happens with gzip and tar

  • after getting an error message (own fault, typos, etc.)
  • using autocomplete

CTRL+C somehow solves the problem in so far as I can work on and have (up to now) no problems with other commands EXCEPT tar. Thus, the problem is repeatable. I would very much appreciate help from here on.

I can isolate the problem further, as it had a "comback": As hinted in a comment, un commenting the following section in ~/home/USER/.bashrc

# if ! shopt -oq posix; then
#  if [ -f /usr/share/bash-completion/bash_completion ]; then
#    . /usr/share/bash-completion/bash_completion
#  elif [ -f /etc/bash_completion ]; then
#    . /etc/bash_completion
#  fi
# fi

helped in so far as trying to use autocomplete

  • still sends the Terminal Emulation (pts) into deep freeze when using TAB after the first occurrence of -- until CTRL+C ends it

  • the real terminal (tty) seems to ignore TAB completely with gzip and tar. I could live that and a long face, but then … really?

Config Files The other config file (I know) for completion would be /etc/bash.bashrc which would turn completion off completely I guess. Not good. The config files for the terminal emulator doesn't have any settings for autocomplete or such

I can type some characters and then the Terminal freezes – takes no more keystrokes. This happens both in an emulated terminal window (pts) in the GUI and also "real" promt (tty).

I work from a keyboard connected via USB, and not on a laptop or the like.

What would be a proper way to kill a terminal session like: »kill tty1 from tty2« because this is exactly what I'm stuck here!

  • I dunno what's going on there, but.. maybe CTRL+Q? – mikeserv Aug 30 '14 at 19:55
  • @mikeserv in the emulated or the real terminal? I can close the emulated (GUI) through a button (which still is quite annoying), but this doesn't help in the real thing (still stuck, only accepting the CMD+ALT+Fn salute) – erch Aug 30 '14 at 20:04
  • @mikeserv CTRL+Q did nothing, CTRL+C helped - updated the question. BUT: "Don't use autocomplete with tar" can't be a solution… thanks anyway, you hinted into a direction where I found help (somehow). – erch Aug 31 '14 at 18:03
  • 1
    Most probably it is completion problem and has nothing to do with terminal but with shell (bash/zsh/...). So tell which shell you use and show .bashrc or .zshrc. – jimmij Aug 31 '14 at 21:22
  • 2
    Has the current working directory got many (hundreds, thousands, +) of files / directories in it? – Joshua Miller Aug 31 '14 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.