3

I have tried installing FreeBSD-10.0-RELEASE-i386-dvd1.iso into VirtualBox 3 times already today (each time starting from a fresh creation of a VM) and right when I'm about to Exit (Apply configuration and exit installer) the Final Configuration stage, I get this Abort error:

FreeBSD Installer - Abort

So then I either have to Restart or Exit...which is obviously not my end goal. I want to give FreeBSD a test drive in VirtualBox so I really want it to get installed. Hopefully someone can help.

Possibly relevant details:

  • Host OS: 64-bit Arch Linux (Antergos)
  • VirtualBox 4.3.14
  • MD5 of ISO used checks out

Update 1

Opened another shell and checked /tmp/bsdinstall_log. Here are the last lines:

bsdinstall_log

I assume umount failed?

Update 2

As suggested in the comments, I disabled Enable VT-x/AMD-V and it aborts after I set the root password.

bsdinstall_disable_vt-x_amd-v

The Abort dialog follows this screen

  • It says installation step has been aborted, which means you tried to skip a step. Did you skip anything? – toxemicsquire Aug 30 '14 at 17:10
  • @toxemicsquire No. I followed the installation guide from the FreeBSD handbook. That's why it's baffling why I get an error saying I skipped a step. – baktin Aug 30 '14 at 23:12
  • @somethingSomething See update 2 in my question. – baktin Aug 30 '14 at 23:45
  • 1
    Have you read errata and tried to set set vfs.unmapped_buf_allowed=0 before boot, as advised? – julp Aug 31 '14 at 0:23
  • Try going to the virtual machine's settings and enable PAE/NX. I was able to put together a install without problems and without using the command given in the errata. – Renan Aug 31 '14 at 1:30
2

"Unstable" FreeBSD 10/i386 on VirtualBox, Xen, KVM

For FreeBSD installation

On FreeBSD boot menu, when booting from installation media, choose: 3. Escape to loader prompt to enter the following commands:

  1. set vfs.unmapped_buf_allowed=0 (enter)
  2. boot (enter)

Then proceed to FreeBSD installation as usual.

To run your new FreeBSD system

Two solutions:

  • before leaving FreeBSD installation, at the end, when it asks for opening a shell (which is chrooted on / of your new system), answer yes, modify /boot/loader.conf (echo 'vfs.unmapped_buf_allowed=0' >> /boot/loader.conf) then exit when you have done to reboot on it
  • or, the first time you boot it, repeat the steps you have done for installation then add this line to your loader.conf (echo 'vfs.unmapped_buf_allowed=0' >> /boot/loader.conf)

Source : FreeBSD 10.0 errata

0

this was happening to me i came googling for it.

I fixed it by just increasing the vm ram in virtualbox from 128MB to 384MB, by default virtaulbox gave it 128 MB as soon as i selected freeBSD, but it recommends 768 MB for a similar net install version of debian. i dont think debian non-gui needs ~7 times more ram then freeBSD non-gui :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.