I am using Linux Mint 14 XFCE. I am trying to remove the default XFCE window manager shortcuts for workspace switching (Ctrl-F1, Ctrl-F2, etc.), as described in this question.

The answers there don't have any effect for me. If I go into Settings->Window Manger->Keyboard, nothing I do has any effect. If I click on a setting and hit "Clear", the setting stays there unchanged. If I double-click on a setting and choose a new shortcut key, the original settings stays there unchanged. If I go into Settings Editor (as described in the other answer to that question) and attempt to reset the settings there, nothing has any effect still.

What is going on? How can I get XFCE to let me change the keyboard shortcut settings?

  • This link could be a good start point for a solution.Take a look at "Keyboard" section – MickyInTheSky Sep 1 '14 at 11:41
  • @MickyInTheSky: That page says "The shortcuts to handle the window manager are defined in the Settings Manager > Window Manager Settings > Keyboard." That's what I'm already using, but it has no effect. It also says something about a "default theme" and creating a new theme, but my settings manager doesn't have any such thing (there is only the list of shortcuts, no way to create a new theme). – BrenBarn Sep 1 '14 at 17:56
  • It is a strange behavior. I'm using linux Mint 13 and I 'm able to manage the shortcuts with the command line: xfce4-keyboard-settings – MickyInTheSky Sep 2 '14 at 10:38

I had the same issue in mint 17 xfce (with both wm shortcuts like Ctrl-F1 and keyboard shortcuts like Alt-F2). I don't like the way how I fixed it but I could not find a better solution. First, I searched for all keyboard configuration files:

$ locate xfce4-keyboard-shortcuts.xml
~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
/usr/share/mint-configuration-xfce/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

Then I removed the file from home, did copies of system files and removed all shortcuts which I wanted to free in both system files. After reboot these shortcuts finally gone.

  • Instead of removing the ~/.config file, I suggest just deleting its contents, but leave it behind. (It got recreated on next login when I deleted the whole file.) – Darren Cook Jun 25 '17 at 10:52

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.