0

I tried to install pandoc on manjaro and therefore I installed ghc and caball-install, but I got an error by executing "cabal update"

$ cabal update
Downloading the latest package list from hackage.haskell.org
cabal: Codec.Compression.Zlib: premature end of compressed stream

I also were not able to install Pandoc with help AUR.

  • 1
    Sounds more like an in an internet issue more than anything else. Check your connection etc. The issue may also be on the server end, in which case try again in a couple of hours. Failing that, please add the contents of your .cabal/config file and also tell use which version of cabal you have. – Graeme Aug 30 '14 at 6:44
  • Doesn't your distribution have a binary package for this? – Faheem Mitha Aug 30 '14 at 8:20
  • @Faheem: the pandoc development is very fast-paced, packages are often outdated. – Jan Aug 30 '14 at 10:27
  • Enabling [haskell-core] and installing their binary package for pandoc is the most sensible solution. – HalosGhost Aug 30 '14 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.