4

I am trying to install new version of vlc on Linux Mint 16. I have tried tutorials on how to do it and no success. When I am trying to install it with apt-get install vlc I get the same version 2.0.8. How to solve this.

Example in command line:

Command:

    sudo add-apt-repository ppa:videolan/master-daily

    Output:

    You are about to add the following PPA to your system:
     This PPA contains daily builds from the VLC development branch.
     More info: https://launchpad.net/~videolan/+archive/ubuntu/master-daily
    Press [ENTER] to continue or ctrl-c to cancel adding it

    Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.DncfZniK1d --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 801DF724
    gpg: requesting key 801DF724 from hkp server keyserver.ubuntu.com
    gpg: key 801DF724: "Launchpad Daily Build of master branch" not changed
    gpg: Total number processed: 1
    gpg:              unchanged: 1

Command:

sudo apt-get update && sudo apt-get install vlc

Output:

Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
**vlc is already the newest version.**
The following package was automatically installed and is no longer required:
  libsvga1
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I have tried this links so far:

http://linuxg.net/how-to-install-vlc-2-1-5-rincewind-on-ubuntu-14-04-linux-mint-17-pinguy-os-14-04-and-other-ubuntu-14-04-derivatives/

How to install the latest version of VLC (2.1.2) on Ubuntu 12.04?

https://www.youtube.com/watch?v=PnAocwPiU_c

  • Include the output of apt-cache policy vlc, in your question, please. – Faheem Mitha Aug 29 '14 at 15:23
  • @Quentin Are you interested in being able to install this version of VLC for its own sake, or do you need to solve a particular problem (e.g. playing a filetype that no player seems to support). – Anthon Dec 10 '14 at 2:24
  • @Anthon see my comments on eyoung100's answer. There's a bug in 2.0.8 that makes it unusable for my huge playlist, and I was hoping it would be fixed in more recent versions. – Quentin Dec 10 '14 at 9:23
  • @Quentin You write you are on Mint 17 which has vlc 2.1.4. Why downgrade to 2.0.8 which has a bug? Or is the bug in 2.1.4 as well? – Anthon Dec 10 '14 at 9:33
  • @Anthon I actually don't know why I'm stuck with that version, as I didn't downgrade anything. And I can't get apt-get to recognize new versions from any ppa at all. – Quentin Dec 10 '14 at 9:48
1

You can try latest stable version using below PPA.

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc
0
+50

Verify VLC Versions

According to the Web Version of the Repository that you are trying to add, the only versions for Ubuntu that the daily builds will work for are:

  1. Trusty - 14.04
  2. Utopic - 14.10
  3. Vivid - 15.04

Click the Technical Details line in Green on the Link Above, as the versions will change as this Answer ages. To download the proper version, visit the VLC Download Page for Mint. If 12.0.8 is what appears in Software Center after Clicking the Green Install Button, you cant update to 2.1.X. See my Answer in this post for why. Regardless of the distribution, the reasoning applies to all binary distributions.


Why This Behavior Occurs

Since Mint is a Ubuntu Derivative, this should work. The reason it doesn't is because the version of Mint you are using is based on a version of Ubuntu less than 14.04, which is the minimum version in the daily builds repository.

  • Is there no other solution than compiling it from source then ? Edit : I'm on Mint 17. – Quentin Dec 9 '14 at 16:34
  • That is correct, and the Question I linked recommends against compiling from source, as the packages you would need are greater than those versions installed in Mint 17. That's the reason why only 2.0.8 is available, because all the dependencies and libraries match. Upgrading Mint may update some of those Libraries but I can't guarantee that. – eyoung100 Dec 9 '14 at 16:39
  • I actually encounter a bug where VLC spawns hundreds of sh zombies and brings my PC to a crawl... I guess I'll use another player until an upgrade is available. – Quentin Dec 9 '14 at 16:41
  • Instead of trying a daily build, try using the stable builds. Does this tutorial help? Notice the different repository. – eyoung100 Dec 9 '14 at 16:46
  • No luck. I tried quite a lot of supposedly working repositories (including this one, which didn't work any better despite its title), but apt-get never sees any new version. – Quentin Dec 9 '14 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.