3

I wrote this question at stackoverflow and got recommended I prob would have a better shot here.

So I'm trying to install grub customizer so I can make Windows the default OS to boot since I use that more frequently (I'm sorry).

Anyway, I finally got it isntalled, but now I can't start it cause of the error message in the description. My real problem is that, that file do exist... I think... I am a real linux novice. I've only used it from now and then for roughly 6 months. Mostly worked with the allready installed software and other times apt-get has worked!

Anyway! Here is what I get in my terminal.

root@ninjaPanda:~# gksu grub-customizer
grub-customizer: error while loading shared libraries: libarchive.so.13: cannot open shared object file: No such file or directory
root@ninjaPanda:~# ls -l /usr/local/lib/
total 8056
drwxr-sr-x 2 root staff    4096 Aug 29 13:30 grub-customizer
-rw-r--r-- 1 root staff 5217320 Aug 29 13:26 libarchive.a
-rwxr-xr-x 1 root staff     997 Aug 29 13:26 libarchive.la
lrwxrwxrwx 1 root staff      20 Aug 29 13:26 libarchive.so -> libarchive.so.13.1.2
lrwxrwxrwx 1 root staff      20 Aug 29 13:26 libarchive.so.13 -> libarchive.so.13.1.2
-rwxr-xr-x 1 root staff 3002216 Aug 29 13:26 libarchive.so.13.1.2
drwxr-sr-x 2 root staff    4096 Aug 29 13:26 pkgconfig
drwxrwsr-x 4 root staff    4096 Aug 27 18:45 python2.6
drwxr-xr-x 4 root root     4096 Aug 27 18:45 python2.7
drwxrwsr-x 3 root staff    4096 Aug 27 18:45 python3.2
drwxr-sr-x 4 root staff    4096 Aug 27 18:45 site_ruby

Edit: Someone told me it could Possibly /etc/ld.so.conf does not contain /usr/local/lib. and asked me to run this.

root@ninjaPanda:~# ldd grub-customizer
ldd: ./grub-customizer: No such file or directory
1

Edit /etc/ld.so.conf, add /usr/local/lib. After that,

 ldconfig

will re-sync your libraries and the grub-customizer will probably work.

Your ldd command was badly parametrized. There must be a binary named grub-customizer in your path, it is probably in /usr/local/bin, although it isn't guaranteed. If it is so, the best if you call an ldd /usr/local/bin/grub-customizer. But it only need for testing the situation.

Anyways, such things are much better if you install them from the official repository of your distro. If they aren't therein, then only do a such unofficial install. It makes a lot of trouble.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.