2

I've installed ArchLinux successfully on my laptop yesterday. To do this, I've followed the Beginner's guide along with the Raid guide. I could do every step without problem, except the one for the time zone (I got an error with ln -s and /etc/localtime). One other point differs from my installation : on the raid webpage, when you have to edit the HOOKS section, mine is different from the one on the pages. I understood that I only had to had mdadm_udev.

However, when I try to boot my computer, Archlinux seems booting fine. It looks like the OS loads modules without problem, then I got the following failed :

[FAILED] Failed to start Packet Filtering Framework.
See 'systemct1 status iptables.service' for details.
[FAILED] Failed to start IPv6 Packet Filtering Framework.
See 'systemct1 status ip6tables.service' for details.

Then some modules are load again and then I got the last failure :

[FAILED] Failed to start Kerberos 5 KDC.
See 'systemct1 status krb5-kdc.service' for details.

This error seems weird because before it comes, I have some lines like this :

[  OK  ] Started Kerberos 5 KDC.
         Stopping Kerberos 5 KDC...
[  OK  ] Stopped Kerberos 5 KDC.
         Starting Kerberos 5 KDC.

After this, I have a black screen that looks like the terminal which asks me my login. Does any have an idea how to fix this or is this normal ?

PS : If you need all the step of the loading screen I can try to film the screen and type it here.

EDIT :

I don't know if this is a consequence of the failure of this module but I can't log in as root.

  • What is your complete HOOKS line in /etc/mkinitcpio.conf? – jasonwryan Aug 29 '14 at 19:28
  • The iptables and ip6tables errors can be fixed by creating rule files in /etc/iptables/. Ex: touch /etc/iptables/iptables.rules; touch /etc/iptables/ip6tables.rules. As for the Kerberos errors, I'm still trying to figure it out, because I have the same errors you do on a clean install. – Scotty C. Aug 29 '14 at 20:12
  • @jasonwryan My HOOKS line is : HOOKS="base udev autodetect modconf block mdadm_udev filesystems keyboard fsck". As I said in my topic, I've just added mdadm_udev. – user1382272 Aug 29 '14 at 21:58
  • @ScottyC. Do you also have the bug that doesn't allow you to log in as root ? – user1382272 Aug 29 '14 at 21:59
  • Fortunately, no. I am still able to log in as root. – Scotty C. Aug 30 '14 at 1:06
2

enabling iptables (touch /etc/iptables/...) with an empty ruleset is really a bad idea you should reinstall your system; the bug (enabling of unrequested services - there are much more than iptables) is fixed in ARCH: https://bugs.archlinux.org/task/41711

Edit: maybe you should wait with reinstallation until systemd (https://www.archlinux.org/packages/core/x86_64/systemd/) has the new version 216-2 !

  • Don't you think that I've done something wrong since the beginning ? Effectively, since I don't have the keyboard in the good language I think I must have missed something... BTW, do you have any idea when the new version will be released ? – user1382272 Aug 31 '14 at 12:58
  • @user1382272: You can now just try a new installation; systemd216-3 is now in the core repository – joe Sep 3 '14 at 11:01
2

Edit : Systemd 216-3 is now in the core package, there shouldn't be any bugs now

The fact that you can't log in as root isn't related to the systemd problem. https://bugs.archlinux.org/task/41711 systemd had a problem identifying a first boot and enabled every service; currently, it is only fixed in the [testing] packages.

I recommend the first solution, but I haven't tested them yet (only try one of them at the time obviously)

  1. When you finished installing, run the command below in the chroot just before rebooting.
uuidgen | { read; echo "${REPLY//-}">/etc/machine-id; }
  1. When installing run systemd-machine-id-setup in chroot (arch-chroot) to fix the problem.

  2. While in the chroot, create a file /usr/lib/systemd/system-preset/99-default.preset and add disable *. You'll need to enable dhcpd if you need it.

  3. Install archlinux normally and after booting, disable all services

  4. Wait for systemd 216-2 to hit the core package.

(Forum post from where I took all the solutions : https://bbs.archlinux.org/viewtopic.php?id=186244&p=1)

  • Nice I'll try to install it this afternoon. Sorry for not giving news but I got some personal problems that I had to fix ^^ – user1382272 Sep 4 '14 at 10:03
0

I have the exact same error messages as you, only with me I have no problems logging in as root.

Also 1 week ago I used the same USB stick with the same untouched ISO still on it to install it on a different computer and there I didn't have these errors.

  • I don't know if a clean install will fix this problem. I'll try it and I'll tell you if it works. – user1382272 Aug 30 '14 at 11:02

protected by Community Sep 3 '14 at 11:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.