1

I'm using the current OpenEmbedded system from: http://git.openembedded.org/openembedded-core/tree/

(For what it's worth, I'm also pulling in layers from http://git.openembedded.org/meta-openembedded/tree/ and http://git.yoctoproject.org/cgit/cgit.cgi/meta-xilinx/tree/.)

I have built up a set of recipes and a distro (adapting from an older set of recipes which worked with OpenEmbedded from a couple of years ago), which boots like this:

...
[    2.441070] EXT3-fs (ram0): error: couldn't mount because of unsupported optional features (240)
[    2.450891] EXT2-fs (ram0): error: couldn't mount because of unsupported optional features (240)
[    2.466262] EXT4-fs (ram0): mounted filesystem with ordered data mode. Opts: (null)
[    2.474002] VFS: Mounted root (ext4 filesystem) on device 1:0.
[    2.480845] devtmpfs: mounted
[    2.484107] Freeing unused kernel memory: 200K (c066f000 - c06a1000)
INIT: version 2.88 booting
[    3.200537] EXT4-fs (ram0): re-mounted. Opts: data=ordered
bootlogd: cannot allocate pseudo tty: No such file or directory
[    3.341168] random: dd urandom read with 9 bits of entropy available
chown: unknown user/group root:root
chown: unknown user/group root:root
chown: unknown user/group root:root
chown: unknown user/group root:root
chown: unknown user/group root:root
chown: unknown user/group root:root
chown: unknown user/group root:root
chown: unknown user/group root:root
INIT: Entering runlevel: 5
Configuring network interfaces... ifconfig: SIOCGIFFLAGS: No such device
ifconfig: SIOCSIFADDR: No such device
Starting Dropbear SSH server: dropbear.
Starting HOSTAP Daemon: nl80211 not found.
Starting syslogd/klogd: done
Starting tcf-agent: OK

MYDISTRO 0.1 zc706-zynq7 /dev/ttyPS0

zc706-zynq7 login: [    8.338466] macb e000b000.ps7-ethernet eth0: link up (1000/Full)
zc706-zynq7 login: root
Password:
Login incorrect
zc706-zynq7 login:

(Never mind the "No such device" errors - I can fix that later.)

The problem here is that the usual login method of username="root" (password not even requested) doesn't work. It appears the root user doesn't even exist here! Any expected password for root (such as empty, "root", "admin", etc) doesn't work. I can't get into this system.

After doing some trial and error debugging, I changed my conf/distro/mydistro.conf to comment out these lines:

...
# The following features are required by eglibc for a clean build of the sdk.
#DISTRO_FEATURES_LIBC = "libc-libm libc-backtrace libc-spawn libc-locale-code libc-getlogin libc-posix-regexp libc-ftraverse libc-posix-clang-wchar libc-posix-wchar-io libc-inet libc-crypt libc-nsswitch libc-utmp"
#DISTRO_FEATURES = "ext4 usbhost wifi pci ipv4 ipv6 largefile ${DISTRO_FEATURES_LIBC}"

which causes the default DISTRO_FEATURES to be used from http://git.openembedded.org/openembedded-core/tree/meta/conf/distro/include/default-distrovars.inc (which is included from http://git.openembedded.org/openembedded-core/tree/meta/conf/distro/defaultsetup.conf, which in turn is included by http://git.openembedded.org/openembedded-core/tree/meta/conf/bitbake.conf on line 682).

Now it boots like this:

[    2.446482] EXT3-fs (ram0): error: couldn't mount because of unsupported optional features (240)
[    2.456386] EXT2-fs (ram0): error: couldn't mount because of unsupported optional features (240)
[    2.471774] EXT4-fs (ram0): mounted filesystem with ordered data mode. Opts: (null)
[    2.479516] VFS: Mounted root (ext4 filesystem) on device 1:0.
[    2.486308] devtmpfs: mounted
[    2.489626] Freeing unused kernel memory: 200K (c066f000 - c06a1000)
INIT: version 2.88 booting
[    3.203046] EXT4-fs (ram0): re-mounted. Opts: data=ordered
bootlogd: cannot allocate pseudo tty: No such file or directory
[    3.345494] random: dd urandom read with 8 bits of entropy available
INIT: Entering runlevel: 5
Configuring network interfaces... ifconfig: SIOCGIFFLAGS: No such device
ifconfig: SIOCSIFADDR: No such device
Starting Dropbear SSH server: dropbear.
Starting HOSTAP Daemon: nl80211 not found.
Starting syslogd/klogd: done
Starting tcf-agent: OK

MYDISTRO 0.1 zc706-zynq7 /dev/ttyPS0

zc706-zynq7 login: [    8.348120] macb e000b000.ps7-ethernet eth0: link up (1000/Full)
zc706-zynq7 login: root
root@zc706-zynq7:~#

Yay, the root account works!

The question is now: what is the key missing DISTRO_FEATURE that makes the root account work?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.