I am running FreeBSD 10 on an ASUS M50VM series laptop. I was following along with the handbook to the point at which it gets into using pkg to find software. Every time I run pkg, with or without options or arguments, I get the following output:

$ pkg
The package management tool is not yet installed on your system.
Do you want to fetch and install it now [y/N]: y
Bootstrapping pkg from pkg+http://pkg.FreeBSD.org/freebsd:10:x86:64/latest, please wait...
Verifying signature with trusted certificate pkg.freebsd.org.2013102301... done
pkg: fail to extract pkg-static

My FreeBSD laptop is connected with an Ethernet cable to my router, which I know is providing Internet access, as the Windows desktop I am currently using to post this question is also connected with a similar cable to the same router.

What am I missing? What are possible causes of this issue? What should I check?

4 Answers 4


That dollar sign ($) in the command line prompt makes me suggest you try to run pkg as an ordinary user.

Try to login as root (e.g., by pressing Alt+F2) and run pkg from that session.

  • 2
    Running pkg as root solved the same problem for me. Commented Nov 21, 2014 at 19:25
  • 1
    Resolved here too. Thanks as well for the Alt+F2 tip :) Commented Apr 7, 2016 at 15:17
  • logging in as root fixed this for me also
    – Pwdr
    Commented Aug 25, 2016 at 8:17

Type su in your command prompt. The system will ask for root password. Enter your root password and you will now be running as root.

Now you should be able to install pkgs


I think you might need to download the larger installation image, it comes with more stuff, I think, I know that is true about linux, but not sure about FreeBSD. But I don't think it has anything to do with the internet. I'd say something wrong with the file extractor. Try getting pkg from ports, if it's there.


This happens when you cannot write the extracted pkg files to the install directory. You need root privileges to do it. Your user needs to be in the wheel group to be able to do su or you need to login with the root user. Another interesting example when you have the root privileges, but you have a read-only filesystem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .