0

After installing a lot of packages I finally got ./configure to work, just to get a horrible message

Host support:- checking C flags dependant on host system type... failed configure: error: Unsupported operating system "aix7.1.0.0"

Versions: AIX 7.1 & TomCat 7.0.55 & JAVA 1.6

Any suggestions/ideas?

1 Answer 1

0

No need to make/build/compile. Just install tomcat then (vi etc/profile)

profile had following added on end:

  • JDK_HOME=/usr/java6/jre;export JDK_HOME
  • JAVA_HOME=/usr/java6;export JAVA_HOME
  • CATALINA_HOME=/apps/tomcat;export CATALINA_HOME
  • PATH=$PATH:$JAVA_HOME:$JAVA_HOME/bin:$JDK_HOME:$JDK_HOME/bin:$CATALINA_HOME:$CATALINA_HOME/bin;export PATH

after that I did following 3 steps from command prompt:

  1. $CATALINA_HOME
  2. ./setclasspath.sh
  3. ./startup.sh

I got the following output:

  • Using CATALINA_BASE: /apps/tomcat Using CATALINA_HOME: /apps/tomcat
  • Using CATALINA_TMPDIR: /apps/tomcat/temp
  • Using JRE_HOME: /usr/java6
  • Using CLASSPATH: /apps/tomcat/bin/bootstrap.jar:/apps/tomcat/bin/tomcat-juli.jar
  • Tomcat started.

command --> catalina.sh version

  • Using CATALINA_BASE: /apps/tomcat
  • Using CATALINA_HOME: /apps/tomcat
  • Using CATALINA_TMPDIR: /apps/tomcat/temp
  • Using JRE_HOME: /usr/java6
  • Using CLASSPATH: /apps/tomcat/bin/bootstrap.jar:/apps/tomcat/bin/tomcat-juli.jar
  • Server version: Apache Tomcat/7.0.55
  • Server built: Jul 18 2014 05:34:04
  • Server number: 7.0.55.0
  • OS Name: AIX
  • OS Version: 7.1
  • Architecture: ppc
  • JVM Version: pap3260sr11-20120806_01 (SR11)
  • JVM Vendor: IBM Corporation

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .