2

After installing CentOS 6.5 I removed Gnome Desktop Environment by running

yum groupremove Desktop

Now everything works fine, but whenever the computer starts there is no log-in prompt. The screen just shows CentOS progress bar. I have to press Alt+Ctrl+F6 in order to switch to terminal and see the log-in prompt.

How can I configure CentOS to do this automatically?

  • what's the content of the files /etc/init/start-ttys.conf and /etc/init/start-ttys.override? – pqnet Aug 25 '14 at 16:21
  • There are lots of line breaks in this script, I can't paste it here using mini-Markdown – Nima Aug 25 '14 at 17:45
  • @pqnet This is the content of /etc/init/start/ttys.con I put a > sign at at beginning of each line instead of breaks >start on stopped rc RUNLEVEL=[2345] >env ACTIVE_CONSOLES=/dev/tty[1-6] >env X_TTY=/dev/tty1 >task >script >. /etc/sysconfig/init >for tty in $(echo $ACTIVE_CONSOLES) ; do >[ "$RUNLEVEL" = "5" -a "$tty" = "$X_TTY" ] && continue >initctl start tty TTY=$tty >done >end script – Nima Aug 25 '14 at 17:50
  • Use backticks so the breaks will stay... – Jan Aug 25 '14 at 21:02
  • @Nima you can change your question and add in the information instead of using a comment. – pqnet Aug 26 '14 at 9:56
2

Found the clean answer. Background - when installing the GUI by doing the groupintstall remember that you had to set id:3:initdefault to id:5:initdefault in /etc/inittab before typing init 6 for root to boot the GUI.

So just reset /etc/iniittab back to id:3:initedefault BEFORE! for doing groupremove.

What appears to happen is the system has no way of finding the prompt because it's still readying itself for a GUI install.

It take about 30 seconds to a minute to get the prompt back so be patient.

  • Great Answer!!! I know it's not much but it's short and sweet. Welcome to U&L.SE – eyoung100 Oct 28 '14 at 18:17
0

It may be the case that the login shell is there, but hidden by the progress bar screen. The progress bar can be disabled by removing the rhgb option from the kernel command line.

You can try to edit temporarily the command line directly from grub at boot to test it. For a permanent change you have to edit the file /etc/default/grub and remove the word rhgb from the parameter GRUB_CMDLINE_LINUX. After that you can regenerate the grub configuration file by using

grub2-mkconfig -o /boot/grub/grub.cfg
  • There is no /etc/default/grub/ file in my installation (CentOS 6.5). I manually edited /etc/grub.conf but there is no GRUB_CMDLINE_LINUX parameter in this file and rhgb appears once in this line kernel /boot/vmlinuz-2.6.32-431.el6.x86_64 ro root=UUID=<UUID> rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet. I removed rhgb and after reboot, instead of progress bar some information(about some services starting...etc) where shown, but still no login shell appeared – Nima Aug 26 '14 at 11:23
  • well, then I guess this is not the solution :( Sorry, I don't know more than this and I don't have a CentOS system where to test it. You probably have to wait for someone more experienced to come with a correct answer – pqnet Aug 26 '14 at 11:28
0

Although not a good solution, but adding chvt 2 (or any other valid virtual terminal number instead of 2) to /etc/rc.local seems to work as a temporary solution for me. This makes OS to switch to tty2 automatically.
I'm still looking for a better solution (showing a log-in shell on tty1 instead of CentOS progress bar)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.