5

I have a WD My Passport 1 TB external hard drive which is giving me some problems on different linux machines:

  • When I plug it in, nothing happens
  • Gparted when detecting connected devices says "Error opening /dev/sdb: No such device or address" and it doesn't list the hard drive
  • Typing on terminal sudo fdisk -l the hard drive is not listed

This happens on both my main Debian PC and on my Raspberry Pi, but I can use the hard drive perfectly normally on my Mac.

I can't check its S.M.A.R.T. status since it's a USB hard drive, but I don't think the HDD is failing, because if so it wouldn't work on my Mac. I checked and reformatted the drive several times on my Mac but it still doesn't work on linux.

Any ideas on what's going on?

Edit: here is the output of lsusb:

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 000: ID 1058:0730 Western Digital Technologies, Inc. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 006: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB

As you can see, the device is listed here (Bus 001 Device 000).

Edit x2: This is kern.log file since when the hard drive was connected:

Edit x3: The hard drive has 4 partitions; two are HFS+ and two are FAT32. The partition table is GUID.

Edit x4: I found this question about one error in the kernel log file I found too, which means the USB 3.0 drive is requesting too much power from the computer. However I tried using a USB power splitter cable (so that the HDD could have 1000 mA instead of 500 mA) and it didn't solve the problem. The HDD seems to be rated 600 mA, but I've always used on USB 2.0 ports without problems.

  • What's the output of lsusb? (edit your question with this output) – drs Aug 22 '14 at 17:00
  • When you plug it in, what are the lines added to /var/log/kern.log (or to dmesg)? – derobert Aug 22 '14 at 17:05
  • 1
    Do you get the same messages in your Debian PC's kernel log as you do on the RPi? – derobert Aug 22 '14 at 17:18
  • Also, does this drive have a password enabled on it with the WD utility? – derobert Aug 22 '14 at 17:20
  • @derobert yes, I get the same messages. And no, the drive is not password protected. – user2747949 Aug 22 '14 at 17:24
1

If your harddrive is formatted as HFS+ (which it would be, if it is formatted as a native Mac drive) then you should make sure that hfs drivers are installed on your Linux machines.

On Debian, as root:

apt-get install hfsplus hfsutils hfsprogs

That should enable read access to the drive, but write access will be disabled until you turn OFF journaling (which should be done from within OS X's Disk Utility application).

0

try doing both:

fdisk -l 
mkdir /mnt/sdb1 
edit /etc/fstab file and add line similar to this:
/dev/sdb1       /mnt/sdb1           vfat    defaults        0       0 
mount -a 

if that fails try this:

sudo fdisk -l  
Then mount with 
sudo mount -t ntfs(depends) /dev/sdb1 /media

This has got to work, if its Linux and it has a USB port, you have to be able to mount the drive unless there's a hardware issue on both ends. Good Luck.

0

Perhaps I misread your kern.log but in this file, your drive seems to be referenced as /dev/sda not /dev/sdb. Did you try to use usbcore.old_scheme_first=1 as a grub boot parameter?

Anyway, according to Device descriptor read/64, error-110 it's a power related trouble and there seems to be some kind of workaround here. The good old "try to turn it off and on again" seems to do the trick (unplugging all your usb stuff before turning on again)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.