5

Due to combined use of Debian jessie, that uses systemd by default, and sdwdate (that uses Slow Clock Adjuster ( gh )), my system clock is frequently changed.

As a result /var/log/syslog gets endlessly spammed by.

[...]
Aug 22 13:06:15 host systemd[1]: Time has been changed
Aug 22 13:06:16 host systemd[1]: Time has been changed
Aug 22 13:06:16 host systemd[852]: Time has been changed
Aug 22 13:06:17 host systemd[852]: Time has been changed
Aug 22 13:06:17 host systemd[1]: Time has been changed
Aug 22 13:06:18 host systemd[1]: Time has been changed
[...]

Running sudo service rsyslog stop stops the spam, but this is not a real solution.

This was not an issue on Debian wheezy that used sysvinit.

How can systemd be configured to not send the Time has been changed message to /var/log/syslog?

Related:
How to disable systemd's “Time has been changed” message spam in systemd journal while using sdwdate?

7

Assuming you're using rsyslog for your logging I'd add a filter there to omit these messages. I looked for a method to disable these on the systemd and did not find anything that looked like a promising lead.

:msg, contains, "Time has been changed" ~

You can put this into a file under /etc/rsyslog.d/time_msgs.conf. Be sure to restart rsyslog afterwards.

$ sudo service rsyslog restart

References

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.