1

I am debugging a connectivity issue with my internet connection provider. I have a PPPoE type of connection.

I am working on configuring my router to connect over PPPoE connection. Please note that I am re-configuring the same router which worked for the same connection so its not a router issue.

I tried to connect the WAN line to my laptop and tried to configure pppd (running Arch Linux)

What I am trying to understand is if the LAN interface should already have IP before I authenticate using PPPoE? I am not sure how PPPoE works, whether it gets an IP over normal DHCP and establishes a session using PPPoE or getting the IP is also part of PPPoE handshake?

Currently, my LAN interface does not get any IP, before or after using ppp dial-up. I am trying to figure out if the WAN connection itself is down or is it just my misconfiguration.

on ppp dial-up I am getting following error,

pppd[30235]: Timeout waiting for PADO packets
pppd[30235]: Unable to complete PPPoE Discovery
  • The IP is assigned as part of the PPP handshake and authentication. – Barmar Aug 22 '14 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.