2

I've installed Xfce4 on my laptop which runs Linux Mint 17 with Cinamon default desktop. Everything works OK and I customized my lightweight Xfce, like change menu location and desktop background that it is similar to my Cinamon desktop and used it for a while.

Suddenly after last restart my desktop background becomes black and there is no option for desktop background change when I right click on desktop. I should mention that

xfdesktop & 

didn't help, which tells it's already running. Some icons like Computer, Home and Oracle VM that was already there is showing, but my Trash or other icons did not. I've tried everywhere in

xfce4-settings-manager

but could not get my desktop background back

running xfdesktop

cause this message:

** (xfdesktop:3068): WARNING **: xfdesktop: another desktop manager is running.

running

killall xfdesktop

results

xfdesktop: no process found

It seems to me another process takes place of xfdesktop I don't know how can I find and replace it

  • Does anything different happen if you kill the running xfdesktop process before attempting to run it again? You can do this with killall xfdesktop (then run that again a few seconds later, and if you don't get xfdesktop: no process found, forcibly kill it with killall -KILL xfdesktop). After killing xfdesktop, try running it again, this time without &. The & isn't causing the problem, but by running it in the foreground you're more likely to see output in the terminal that might reveal the nature of the problem. (You can edit your question with detailed results.) – Eliah Kagan Aug 21 '14 at 21:52
  • Have you tried to run xfdesktop-settings and change the background there? – Ernest A Aug 21 '14 at 22:52
  • running xfdesktop cause this message: ** (xfdesktop:3068): WARNING **: xfdesktop: another desktop manager is running. – Serjik Aug 22 '14 at 4:35
3

I could get my desktop back with the following steps:

1.Run:

xfce4-settings-manager

2.Select Session and Startup

3.Select Application Autostart tab

4.click Add

5.On the window appeared enter name, description and

xfdesktop --replace

as command

6.Logout and Login again

  • I have this issue now with Linux Mint 18 MATE and installed XFCE settings manager to follow your instructions, but Session and Startup is not a thing on it now. – J00S Feb 1 '17 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.