2

I am getting this error in my /var/log/messages file.

dnsmasq-dhcp[xxxx] DHCPDISCOVER(xxxxxx) xx:xx:xx:xx no address available

How can I tell what leases dnsmasq has leased out? And how can I free them up?

I'm running RedHat Enterprise Linux 6.5

1 Answer 1

4

You can expand your range by editing the config file:

vi /etc/dnsmasq.conf

Look for the dhcp-range line:

dhcp-range=192.168.0.10,192.168.0.50,12h

will issue from 192.168.0.10 to 192.168.0.50 with a lease time of 12 hours.

You can see your current leases with:

cat /var/lib/dnsmasq/dnsmasq.leases

That path might differ, depending on your distro. If it's not there, check the config file above for:

dhcp-leasefile=<path to lease file>

Here's a minimal example config:

interface=eth0
dhcp-range=192.168.0.10,192.168.0.50,12h
dhcp-options=3,192.168.0.1

which listens on eth0 and issues 192.168.0.10 to 192.168.0.50 with a lease time of 12 hours. It also sends the default gateway (the 3) as 192.168.0.1.

4
  • all the lines in my /etc/dnsmasq.conf are commented out and I have no /var/lib/misc/dnsmasq.leases file. Aug 20, 2014 at 22:35
  • Hmm! Add your distro to your question - it may help us track it down. Aug 21, 2014 at 5:16
  • Red Hat Enterprise Linux Server release 6.5 Aug 21, 2014 at 15:26
  • You need to configure dnsmasq before it works. I've just installed it on a RHEL6.5 VM and all of /etc/dnsmasq.conf is commented out; just as you found yours. Aug 21, 2014 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .