I am trying to run a program that I downloaded in Ubuntu latest version, but I continue getting an error everytime I try to run the program. It says:

File Not Found: BeautifulSoup

So in order to attempt to fix this, I've downloaded the bs4 beautiful soup package through the command line. I've tried running python, and then importing it by doing, from bs4 import BeautifulSoup.

I have tried many different variations of this and downloading and redownloading it. I've tried running the from bs4 import BeautifulSoup directly from the terminal, but that did not work and returned an error.

Does anyone know anyway to fix this issue or what I need to do?

  • 1
    What program were you trying to run that gave you this error? – HalosGhost Aug 20 '14 at 18:07
  • Have you used pip to install beautifulsoup? – gypaetus Aug 20 '14 at 18:21

You can install the package python-beautifulsoup in a Ubuntu system running the command below as root:

apt-get install python-beautifulsoup

This will install the package under /usr/share/pyshared and importing it should work.

  • i love you so much right now – king Aug 20 '14 at 18:32
  • i used "easy_install" to do it and i got easy install, no idea why that didnt work – king Aug 20 '14 at 18:32
  • Either pip or easy_install should also work but using the ubuntu package will solve the problem – gypaetus Aug 20 '14 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.