1

I installed Debian 7. I wanted a music player, so I tried banshee, xine, amorak, exaile, mp3blaster, totem, lxmusic, xmms2.

After trying all of these, the only that would play any sound was mplayer and various other software based on mplayer, such as gnome-mplayer, gmplayer, etc.

  • I installed all necessary dependencies, recommendations, and suggested software listed for the other music players.
  • I solved the codec problems for the other software. When played, the timers moved, but there was no sound.

What makes mplayer different from the other players that allows it to play audio?

  • Check out vlc. That's the other major player. – Faheem Mitha Aug 20 '14 at 2:53
  • Missing codecs? – daisy Aug 20 '14 at 7:28
  • In some cases, the software, when run from the terminal, reported missing codec errors, but I fixed them. The players play the file. – Village Aug 20 '14 at 7:32
2

Probably you did not install corresponding gstream plugins.

Without proper audio/video decoders, it won't play. MPlayer does not rely on this, so it works

  • I installed everything with *gstream* in the name found in aptitude. Why does mplayer` not reply on this? It uses something else? – Village Aug 20 '14 at 7:33
  • @Village There're certain codecs that're not provided by default, you need to install some 3rdparty codecs IIRC – daisy Aug 20 '14 at 7:39
  • @Village It's in the repository but need to be enabled – daisy Aug 20 '14 at 7:39
1

There are different ways to play sound in Linux. There are: pulseaudio, alsa, oss, jack. There are also multiple higher level libs like: sdl, openal.

Mplayer can use a lot of this and can select different way to access audio if one way doesn't work. Look into mplayer -ao help. Find out which ao works for you by logs and check by specifying ao explicitly. In case of alsa find correct device. Find out how your not working program plays sounds and find the difference.

In case of alsa pay attention to which device is used to play, try different devices (in mplayer -ao alsa:device=...) - there may be stereo, surround and etc and something may not work.

Also you may use different or wrong audio card (you may have HDMI and integrated for example).

In case of pulseaudio check that you volume level is correct.

Use alsamixer to check volume levels in alsa and f6 to select and check list of your alsa devices.

Use pavucontrol to setup your pulseaudio.

In case if pulseaudio doesn't work you can also remove it =)

  • Should both`Alsa and PulseAudio be installed together, or is it one must use one or the other? – Village Aug 20 '14 at 7:35
  • 1
    Alsa (advanced linux sound architecture, library name is libasound2) is base library of sound playback in Linux. Pulseaudio uses alsa. Pulseaudio add features like dynamic device allocation, per-application volume control, sharing of the sound device between multiple applications (this can also be implemented in alsa), network sound (this rarely used). – gena2x Aug 20 '14 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.