0

I am building my first LFS 7.5 using Linux Mint-13 (32-bit) While preparing Binutils for compilation(5.4.1):

../binutils-2.24/configure  \
--prefix=/tools             \                     
--with-sysroot=$LFS         \
--with-lib-path=/tools/lib  \
--target=$LFS_TGT               \
--disable-nls                   \
--disable-werror.

I have got following error :

bash: --with-sysroot=/mnt/lfs--with-lib-path=/tools/lib--target=i686-   lfs-linux-gnu: No such file or directory

This is the output I'm getting:

lfs@jaassi-virtual-machine /mnt/lfs/tools/binutils-2.24 $ ../binutils-2.24/configure \
--prefix=/tools/binutils-2.24
 binutils-2.24/         binutils-2.24.tar.bz2  
> --prefix=/tools/binutils-2.24
  binutils-2.24/         binutils-2.24.tar.bz2  
> --prefix=/tools/binutils-2.24   
> checking build system type... i686-pc-linux-gnu
> checking host system type... i686-pc-linux-gnu
  checking target system type... i686-pc-linux-gnu
  checking for a BSD-compatible install... /usr/bin/install -c
  checking whether ln works... yes
  checking whether ln -s works... yes 
  checking for a sed that does not truncate output... /bin/sed
  checking for gawk... gawk
  checking for gcc... gcc
  checking for C compiler default output file name... a.out 
  checking whether the C compiler works... yes
  checking whether we are cross compiling... no
  checking for suffix of executables... 
  checking for suffix of object files... o
  checking whether we are using the GNU C compiler... yes
  checking whether gcc accepts -g... yes
  checking for gcc option to accept ISO C89... none needed
  checking for g++... g++
  checking whether we are using the GNU C++ compiler... yes
  checking whether g++ accepts -g... yes
  checking whether g++ accepts -static-libstdc++ -static-libgcc... yes
  checking for gnatbind... no
  checking for gnatmake... no
  checking whether compiler driver understands Ada... no
  checking how to compare bootstrapped objects... cmp --ignore-initial=16 $$f1 $$f2
  checking for objdir... .libs
  checking for version 0.10 of ISL... no
  checking for version 0.11 of ISL... no
  checking for default BUILD_CONFIG... 
  checking for bison... bison -y
  checking for bison... bison
  checking for gm4... no
  checking for gnum4... no
  checking for m4... m4
  checking for flex... no
  checking for lex... no
  checking for flex... no
  checking for makeinfo... no
  checking for expect... no
  checking for runtest... no
  checking for ar... ar
  checking for as... as
  checking for dlltool... no
  checking for ld... ld
  checking for lipo... no
  checking for nm... nm
  checking for ranlib... ranlib
  checking for strip... strip
  checking for windres... no
  checking for windmc... no
  checking for objcopy... objcopy
  checking for objdump... objdump
  checking for readelf... readelf
  checking for cc... cc
  checking for c++... c++
  checking for gcc... gcc
  checking for gcj... no
  checking for gfortran... no
  checking for gccgo... no
  checking for ar... ar
  checking for as... as
  checking for dlltool... no
  checking for ld... ld
  checking for lipo... no
  checking for nm... nm
  checking for objdump... objdump
  checking for ranlib... ranlib
  checking for readelf... readelf
  checking for strip... strip
  checking for windres... no
  checking for windmc... no
  checking where to find the target ar... just compiled
  checking where to find the target as... just compiled
  checking where to find the target cc... host tool
  checking where to find the target c++... host tool
  checking where to find the target c++ for libstdc++... host tool
  checking where to find the target dlltool... just compiled
  checking where to find the target gcc... host tool
  checking where to find the target gcj... host tool
  checking where to find the target gfortran... host tool
  checking where to find the target gccgo... host tool
  checking where to find the target ld... just compiled
  checking where to find the target lipo... host tool
  checking where to find the target nm... just compiled
  checking where to find the target objdump... just compiled
  checking where to find the target ranlib... just compiled
  checking where to find the target readelf... just compiled
  checking where to find the target strip... just compiled
  checking where to find the target windres... just compiled
  checking where to find the target windmc... just compiled
  checking whether to enable maintainer-specific portions of Makefiles... no
  configure: creating ./config.status
  config.status: creating Makefile
  lfs@jaassi-virtual-machine /mnt/lfs/tools/binutils-2.24 $ --with-sysroot=$LFS
  $LFS      $LFS_TGT  
  lfs@jaassi-virtual-machine /mnt/lfs/tools/binutils-2.24 $ --with-sysroot=$LFS\
  > --with-lib-path=/tools/lib\
  > --target=$LFS_TGT \
  > --disable-nls\
  > --disable-werror
  bash: --with-sysroot=/mnt/lfs--with-lib-path=/tools/lib--target=i686-   lfs-linux-gnu: No such file or directory

How can I resolve this?

2
  • 1
    It seems there is no space between parameter. – alpert Aug 19 '14 at 19:48
  • @alpertek...finally able to resolve the problum ...thanx buddy – jassi Aug 20 '14 at 13:00
0

There must be space between parameters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.