I've set up an old machine running Ubuntu server 13.1. I can access it remotely with webmin and I was able to install apache that way. What I would like to be able to do is to put web pages and be able to open them in a browser on any computer connect to my local network. Any tutorial I have followed hasn't worked for me so far. But today, using the default local server, I was able to open my webpage through webmin's HTTP tunnel with


When I try this in a browser it wont work. Could anyone help me out here and give some tips on what to do to get apache serving web pages in my browser?

Edit: I belive this also needs to be mentioned :) My server ip is but when I type this it just brings me to webmin, not my webpage. Is there some configuration I need to do to access webpages with this ip?

  • What does cat /etc/webmin/miniserv.conf | grep port return? – garethTheRed Aug 19 '14 at 12:04
  • @garethTheRed it shows port=10000 – javawocky Aug 19 '14 at 12:55
  • Hmm! Please paste the output of ss -tl in your question. – garethTheRed Aug 19 '14 at 12:58
  • I got it! webmin is on port 10000, but when I appended port 80 to the end of the ip it worked! – javawocky Aug 19 '14 at 13:03
  • Odd. Did your browser's history automatically place a 10000 there if you didn't specify 80? The latter is the default port and shouldn't need to be specified. Glad it's working though. – garethTheRed Aug 19 '14 at 13:05

It sounds like there may be a conflict on port 80. You may need to change the port number used by one of the applications. It would probably be better to change the Webmin port to another number. This should be possible in the config files.

| improve this answer | |
  • Webmin is on 10000, but that was what I was doing wrong. I was using that port number instead of 80 to try and access web pages – javawocky Aug 19 '14 at 13:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.