2

I'm trying to install a Windows7 guest on a Linux host with Virtual box. I've set my guest up but when I hit start, I keep getting the message:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

I've ran/etc/init.d/vboxdrv setup n the shell but nothing happens and the error keeps popping up, how can I get this resolved?
Oh yeah, and I've installed dkms already:
# apt-get install dkms

EDIT 1

# modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found.

EDIT 2

There's virtualbox-guest-dkms and virtualbox-dkms and I have them both installed but I still get the same error...

  • It seems like this is a fairly common issue. Try the steps outlined at these sites. Also – Warwick Aug 18 '14 at 2:02
  • Does you distro provide prebuilt packages for the VirtualBox modules (if so, use those)? What happens if you modprobe vboxdrv manually? – Renan Aug 18 '14 at 2:44
  • @Renan Mydistribution is Kubuntu 14.04. Please see above EDIT 1 – cerr Aug 18 '14 at 2:47
1

Remember to use sudo. Run it like this and it will work:

sudo apt-get install dkms
sudo su
/etc/init.d/vboxdrv setup

see if it works now.

I am trying to use it too. I had the same problem. I did the following in the terminal:

sudo su

I don't have a virtual machine yet, but this problem/error is solved for me after doing this.

  • Generally when people represent the shell prompt with # instead of $, it means they're running as root – Michael Mrozek Sep 9 '14 at 3:24
  • On RedHat/Fedora, it's yum install dkms. kernel-devel might also be required. – basic6 Oct 24 '15 at 16:07
1

You need to install the VirtualBox kernel modules. I believe the package you need is virtualbox-ose-dkms.

1

I was banging my head with this one too.

I was using the virtualbox.repo with CentOS 7

Here is what I came up with:

# yum remove VirtualBox-5.0
# yum -y update kernel kernel-firmware
# yum -y install kernel-devel
# yum -y install epel-release
# yum -y install dkms
# yum -y install VirtualBox-5.0
0

Took me a long time to solve this issue. Had this problem with vBox across 2 distros (Ubuntu and Arch).

I had dkms and all the modules already installed and compiled into my kernel, yet I still got a module related error message when I tried to run a vBox virtual machine.

If your vBox GUI starts without a hitch but get an error telling you to install the VBoxDrv kernel module (or any other modules) when you try to run a virtual machine, your problems are not related to installing the modules into your kernel but activating them in modprobe which the module installation script fails to do.

To load a module manually (such as vboxdrv), open a terminal prompt and put in:

sudo modprobe vboxdrv

if your error message is telling you that your missing another module, be sure to activate it as well.

If you Virtual Machine runs after that without giving you an error message, you've found the solution. Then you can activate the vboxdrv module permanently by going to /etc/modules-load.d/ (or whatever .d directory your modprobe uses) and making a .conf file within it (such as vbox.conf). In the .conf file, put in the names of the vbox kernel modules you want to add, such as: vboxdrv and optionally vboxnetadp, vboxnetflt and vboxpci. If you don't know what they do, see the excerpt below that I took out of vBox's wiki. Save the .conf file and reboot

From Vbox's wiki:

vboxnetadp and vboxnetflt are both needed when you intend to use the "Host-only networking" feature. More precisely, vboxnetadp is needed to create the host interface in the VirtualBox global preferences, and vboxnetflt is needed to launch a virtual machine using that network interface.

vboxpci is needed when your virtual machine needs to pass through a PCI device on your host.

Note: If the VirtualBox kernel modules were loaded in the kernel while you updated the modules, you need to reload them manually to use the new updated version. To do it, run vboxreload as root.

0

First: Uninstall virtualbox-dkms and its configurations by running the below commands:

sudo apt-get remove virtualbox-dkms
sudo apt-get remove --purge virtualbox-dkms

Second: Install Linux headers and Linux image by running the below command:

sudo apt-get install -y linux-headers-amd64 linux-image-amd64

Last: Install virtualbox-dkms

sudo apt-get install -y virtualbox-dkms
0

Follow these steps it solved for me 1.Boot your device and then disable the secure boot 2.Then run sudo apt-get install virtualbox in your terminal I think this will solve your problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.