3

Well, I had my hard drive crashed some weeks ago. My Ubuntu (14.04) automagically froze and after the moment I pressed the restart button, and it prompted me with busybox prompt. I tried booting with the Live Ubuntu CD, but could not mount my drive (root partition). I continued booting with my Live USB of Mint 17 (cursing Ubuntu, of course) with some persistence space.

After some days, the drive stopped appearing (in the BIOS too).

Just before writing this question, it suddenly appeared, (first in my board's boot menu). I tried running Gparted to format the drive (so that i could install Mint), but gparted aborted with an error. Details Here! . And eventually it stopped appearing.

Could anyone tell me what's wrong with my drive by seeing the gparted error details?

Gparted Error Details:

GParted 0.18.0 --enable-libparted-dmraid --enable-online-resize

Libparted 2.3
Format /dev/sda5 as ext4  00:06:35    ( ERROR )

calibrate /dev/sda5  00:00:00    ( SUCCESS )

path: /dev/sda5
start: 4001792
end: 625141759
size: 621139968 (296.18 GiB)
clear old file system signatures in /dev/sda5  00:00:00    ( SUCCESS )

write 68.00 KiB of zeros at byte offset 0  00:00:00    ( SUCCESS )
write 4.00 KiB of zeros at byte offset 67108864  00:00:00    ( SUCCESS )
write 4.00 KiB of zeros at byte offset 274877906944  00:00:00    ( SUCCESS )
write 4.00 KiB of zeros at byte offset 318023659520  00:00:00    ( SUCCESS )
flush operating system cache of /dev/sda  00:00:00    ( SUCCESS )
set partition type on /dev/sda5  00:00:00    ( SUCCESS )

new partition type: ext4
create new ext4 file system  00:06:35    ( ERROR )

mkfs.ext4 -L "" /dev/sda5

Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
19415040 inodes, 77642496 blocks
3882124 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=4294967296
2370 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424, 20480000, 23887872, 71663616

Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: 2/2370
mke2fs 1.42.9 (4-Feb-2014)

Warning, had trouble writing out superblocks.

========================================
  • It would be best if you included this information here instead of linking it to an outside site. – mdpc Aug 17 '14 at 21:44
  • gparted isn't a very useful tool for diagnosing disk errors: the error messages in your question amount to saying "it didn't work right". Does smartctl -a /dev/sda say anything useful about your drive? – Mark Aug 18 '14 at 6:57
  • @Mark I deleted and re-created the partition and things seem to work. I got a couple of error messages later on and gooling-ing the last lines of dmesg lead me to fsck and it's working fine now! I still get couple of wierd errors sometimes like "WRITE DMA... failed or sth". Anyways Thanks! – cipher Sep 5 '14 at 10:04
2

Error such as "Warning, had trouble writing out superblocks" usually indicate a problem with the hardware. This could be as simple as a loose cable, or could indicate a failing hard drive. The suggestion to run smartctl on the drive is a good idea. Personally I check the drives using gsmartcontrol which provides a graphical user interface. After a disk error occurs, you might also run dmesg and look at the last few lines any indication of hardware problems.

Since you mention that the hard drive sometimes disappears from the BIOS, I strongly suspect that the problem is a failing hard drive. If this is the case, then the operating system is not to blame.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.