I have been trying to start a small home server, using Ubuntu 10.04 Server edition. The installation process finished, and I got an error from Grub saying that it was "out of disk". After a bit of debugging, I created and ran Grub from a CD, but the best I could do was get to a Grub shell, where using the boot command gave the error message error: no loaded kernel.

After more playing around, I decided to try re-installing Ubuntu, and booted it up to find a Grub terminal (not splash menu, but not recovery mode) telling me that it had an error, no loaded kernel again. The same thing happens when trying to follow instructions on loading an OS from grub, at the linux /vmlinux root=/dev/sda1 command. After many searches, all of the information I can find is this:

  • The error has been reported when upgrading in Ubuntu 9, and can be solved by installing a later version of Grub.
  • The Grub shell will load without selection if Grub can't find a configuration file.

The first doesn't seem to be applicable, but the second, along with the exact commands that fail, seem to point to the problem being getting info off of the hard drive.

The operating system is Ubuntu 10.04.2 Server LTS, running on the internal hard drive of a Compaq Armada m700 (very old, very slow, but I just want a text-based/LAMP server).

Any suggestions on how to get the kernel to load, or another solution? Again, I have tried re-installing the OS, booting multiple times, and running Grub off of a cd.

  • Did you check (from live cd) that grub config and kernel images in /boot are correctly installed? Commented Jun 16, 2011 at 23:45
  • Er, no, might you have a pointer to instructions for checking the installation? Commented Jun 17, 2011 at 0:14
  • Boot into live cd, mount the partition where you installed ubuntu, check at least that initrd.img and vmlinuz are present in /boot and grub.cfg is present in /boot/grub Commented Jun 17, 2011 at 7:38
  • @Anton Sorry to take a while to get back to you, but I have been working on a bunch of other things. I just booted into the live cd, and I found initrd.img-2.6.32-28-generic-pae and vmlinux-2.6.32-28-generic-pae in /boot, and grub.cfg in /boot/grub. Do you have any idea what happened? Commented Jun 19, 2011 at 20:07
  • I think I understand at part of your problem but can you update question with contents of your grub.cfg (maybe on pastebin), hard drive partitions list (sudo fdisk -l /dev/sda (or whatever is your disk)) and partition where you installed ubuntu? Commented Jun 19, 2011 at 22:11

1 Answer 1


You can try installing grub at /dev/sda

For manually loading kernel, you can try following:

set root (hd0,1)
linux /vmlinuz root=/dev/sda1
initrd /initrd.img

here please note that you need to put your kernel version. For example, my kernel version is 3.0.0-12 (initrd.img-3.0.0-12-generic & vmlinuz-3.0.0-12-generic). To load this kernel, you have to try following:

set root (hd0,1)
linux /vmlinuz-3.0.0-12-generic root=/dev/sda1
initrd /initrd.img-3.0.0-12-generic

You will find your available versions by pressing after typing linux or initrd command. Another thing is, make sure your root resides on /dev/sda1

Best luck :)

  • Ok, thank you, but actually I have given up on the problem, got a VPS, and haven't used the laptop in ages. Hopefully someone else will use your answer, and thanks for replying to an old question. Commented Nov 8, 2011 at 22:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .