2

I've just installed arch linux on a UEFI motherboard. as bootloader I installed "gummiboot". I've got the following problem, when the computer stars I recive the message:

"Linux Boot Manager has been blocked due to current privacy policy."

and then starts Windows 8. I disabled the secure boot from the bios, but still not working.

what should I do?

SOLUTION:

I've found in the settings of my Windows 8 (was installed when I bought the laptop) something that says: "total disable secure boot". I have pressed it and then it worked to boot the arch linux bootloader.

closed as off-topic by mikeserv, polym, Braiam, derobert, cuonglm Aug 16 '14 at 18:56

  • This question does not appear to be about Unix or Linux within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You have to get a UEFI secure-boot certificate - or configure it to accept self-signed certificates. This must be done in either Windows 8's "firmware" config settings or in the UEFI boot interface itself. It is entirely implementation specific, and it is possible that it cannot be done at all (absolutely worst case). The best place to ask this question is on your computer manufacturer's support forums. If it is any help though, it is possible you can just scan the firmware menu and locate a disable secureboot setting. If so, do. – mikeserv Aug 16 '14 at 16:30
  • 2
    This question appears to be off-topic because it is about an implementation specfic hardware security feature. The manufacturer should be consulted. – mikeserv Aug 16 '14 at 16:49
  • I disabled the secure-boot from bios, but there wasn't any change. – Paul Aug 16 '14 at 16:56
  • you didn't do that in BIOS - you don't have one. Again, this is a question you need to ask your manufacturer, but it could be gummiboot is still trying to load with its secureboot certificate and it shouldn't be. It could also be a setting that needs to be configured in Windows - Windows will reset the secureboot if it is configured to do so. Your manufacturer will know. It might also be that you need to move $ESP/EFI/BOOT/BOOTx64.efi. – mikeserv Aug 16 '14 at 17:26
  • 1
    So.... you've changed to title to include "solved", what was the solution? If it wasn't something silly (e.g., a typo), please post it as an answer. – derobert Aug 16 '14 at 18:34