4

I am running Linux Mint 17 with KDE and display drivers from Nvidia. I've configured the display settings using nvidia-settings, and when I first start up everything appears to work correctly.

However, when I log in and KDE is loaded, it does something to my display setup which turns off one of my three connected screens. Using the KDE Display settings I am unable to turn the screen back on, but restarting the session and returning to the login screen shows the login dialog on this screen as intended.

How do I stop KDE from messing with my screen setup? Alternatively, why is one of my monitors getting turned off? FWIW, the monitor affected by this is connected via HDMI while the other two that keep working are using DVI.

  • I think that the best solution to this problem is going to be different than what you are asking. Stopping KDE from messing with the screens is prob not going to happen but it should be possible to get it to mess with them in the correct way. I would also say that leaving 3 monitors on while your PC sits at the login screen seems like a pointless waste as well. – krowe Aug 16 '14 at 10:28
  • @krowe, I'd be more than happy if there's a solution that makes KDE set up my screens correctly rather than not trying at all. Regarding the login screen, this is for my home PC, it spends about 10 seconds on that screen each time I start up and that's it. – SoftMemes Aug 16 '14 at 10:34
6

There's a module in KDE called KScreen that is doing this.

To disable it, go to K Menu->Computer->System Settings->System Administration->Startup and Shutdown->Service Manager. Look for a service called KScreen, and uncheck the Use box. You can stop the service now if you want.

You can also manually edit $HOME/.kde/share/config/kdedrc, and add these lines:

[Module-kscreen]
autoload=false

This stops KDE messing with monitor configurations, and will stick with the one KDM provided at startup.

Kscreen is a per-user service; you'll need to set it for every user unless you have a policy set up.

4

I've had similar issues and I tried solutions telling me to add xrandr commands to

~/.kde/share/config/krandrrc

but those turned out not to work. The only thing I got to work reliably was to add xrandr commands to my .profile:

xrandr --output "VGA1" --primary --mode 1920x1200 --output "HDMI2" --right-of "VGA1" --mode 1920x1200

First run xrandr without any options, that will list your available screens and their available resolutions, then you can compose a list of xrandr options using the xrandr output as a starting point.

My setup is: a laptop in a docking station, docking station has two identical monitors attached, one via DVI cable and the other via VGA cable. In my example above, the display attached with VGA cable is "VGA1", the display attached with DVI cable is "HDMI2".

  • If the second display is connected via VGA cable, why do you call it "HDMI2" the xrandr command? :) – Erathiel Jun 1 '15 at 8:22
  • Hi Erathiel, good question. The VGA display is listed as "VGA1", it's the DVI cable display that is listed as HDMI2, no idea why. – Adam.at.Epsilon Jun 1 '15 at 9:34
  • DBI is Digital Video Interface, and HDMI is High Definition Multimedia Interface - to oversimplify - HDMI is just DVI + digital sound in one cable. That's why you have simple adapters and cables from DVI to HDMI without any converters. BTW, this answer shows that you need to specify both outputs in one command - I wanted to adjust one ouput at a time and failed. – Tomasz Gandor Feb 15 '16 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.