1

I am having some problem installing 32-bit Fedora20 OS over the network. At the installation summary page, under the software installation source section, using the default closest mirror option, I keep getting the following fatal error during installation:

The following error occurred while installing.
This is a fatal error and installation will be aborted.

error populating transaction: failure:
Packages/b/biosdevname-0.5.0-2.fc20.i686.rpm from anaconda:
[Errno 256] No more mirrors to try.

As it appears that Fedora has some problem locating mirrors, I tried manually specifying a URL for the base repository, such as:

http://ftp.cuhk.edu.hk/pub/linux/fedora/releases/20/Fedora/i386/os/

I tried a few URLs, but all, except the URL closest to where I stay which causes the above fatal error, give me the following error:

Error setting up base repository

Am I missing something?

  • The mirror is correct. Did you tried with other mirrors? – Braiam Aug 19 '14 at 22:20
  • @Braiam, as mentioned above, I did tried manually entering a few other mirror URLs. All didn't work. I suspect the culprit is DNS as after I have given up and install using a full DVD version, I face similar problem doing yum update. I have to manually delete the router ip from the list of nameservers in /etc/resolv.conf to be able to do an update. If I can do the same prior to installing the OS, then maybe I can get the network installation to work. – Question Overflow Aug 20 '14 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.