0

After installing Fedora 20 for first boot, everything is OK.

But after installing some packages and updating, then rebooting the system, after boot the screen goes black or gnome starts. After first click, gnome freezes or screen goes black, but when I disable ati OpenSource driver, gnome starts properly (but gnome-shell uses 50% of cpu cycles because of software rendering).

How can I solve this?

1

Edit:
This is Because some Graphic cards are not supported by ATI open source driver, but installation of ATI proprietary driver on fedora 20 is somewhat tricky and need installation script modification

Follow this instructions to install it:
http://bluehatrecord.wordpress.com/2014/05/10/installing-the-proprietary-amd-catalyst-14-4-fglrx-driver-on-fedora-20-with-kernel-3-14/

Just first install requirements by running this command in terminal:

sudo yum -y install gcc binutils make kernel-devel kernel-headers dkms

and also replace Kernel version in line 7 of patch with your kernel version(run "uname -a" in terminal to find it) for example my kernel version was 3.11 so I used this patch:

--- lib/modules/fglrx/build_mod/firegl_public.c
+++ lib/modules/fglrx/build_mod/firegl_public.c
@@ -1784,7 +1784,11 @@ KCL_TYPE_Uid ATI_API_CALL KCL_GetEffecti
 #else 

 #ifdef current_euid
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,11,0)
+    return __kuid_val(current_euid());
+#else
     return current_euid();
+#endif
 #else
     return current->euid;
 #endif
  • 1
    please improve your answer by adding more details to it – Networker Aug 14 '14 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.