4

When I start Thunderbird or the IDE 'Eclipse', there are no icons in the menu entries. Several solutions found on the Internet suggest things like setting a specific dconf-value, but with my installation (Arch) this is not possible:

% gsettings set org.gnome.desktop.interface menus-have-icons true
No such key 'menus-have-icons'

So what is the current way for enabling these icons?

6

It seems that since GTK 3.10 the value 'menus-have-icons' is deprecated. I found a solution by using this command:

% gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1>}"
|improve this answer|||||
  • 1
    as gsettings or gnome-tweak-tool will overwrite the key, if you want to disable middle click paste you should not disable it via gnome-tweak-tool, instead you should use this style: gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1>,'Gtk/EnablePrimaryPaste': <0>}" – Microsoft Linux TM Sep 7 '14 at 14:10
  • thx Stephan, this works for me on archlinux! – Produnis May 25 '18 at 20:03
1

For those who miss icons in GTK2 or GTK3 applications, but not on GNOME (e.g. KDE + pidgin), one of the easy options is to use lxappearance: on the "Other" tab it has "Show images on buttons" and "Show images in menus" checkboxes, toggling which you can toggle these settings on the fly.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.