1

All groups exist and the users are in their belonging defined group.

[homes]
comment = Home Directories
admin users = @admin
browseable = no
read only = no
create mask = 0750

(Users can't write in their homes. Why?)

[pi]
comment = pi Home Folder
valid users = @admin
write list = @admin
path = /home/pi
read only = no
browseable = yes

(Users from admin group have no write rights. Why?)

[personal]
comment = files
valid users = danny
path = /home/danny/personal
read only = no
browseable = no

(User danny has no write access.)

[downloads]
comment = Download Folder
valid users = @users
write list = @admin
path = /home/danny/downloads
read only = no
guest ok = no

(Admins should have write access but they haven't got it.)

Could you help me analyze the problem here?

0


For Admins :
1. All Admin users should be added to the write list i.e. @admin.
2. All Admin users should be added to the valid users i.e. @users.
3. Set correct group permission on the writable directories.
4. Set password using "smbpasswd"

Don't forget to set the Selinux Context and Boolean if Selinux is enabled

| improve this answer | |
  • I that and it still doesnt work :_ – infected Aug 13 '14 at 12:50
  • What error are you getting? Unable to login, or unable to access share, or unable to access home dir? – Rituraj Aug 13 '14 at 12:56
  • i cant write to any shares as user of the admin grp – infected Aug 13 '14 at 13:30
  • Is selinux enabled??? Set correct selinux context. You don't have permission to write the group or directory. Check that. – Rituraj Aug 13 '14 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.