1

I've installed Debian testing on a Macbook Pro (mid 2014) without keeping OS X on the internal SSD. I've used the following GPT partition layout:

  1. HFS+
  2. EFI on /boot/efi
  3. BTRFS on /
  4. SWAP on swap

I've heard that the Apple implementation of UEFI is different and only boots from a HFS+ partition instead of the default FAT32 partition, so i decided to create a HFS+ partition. The Debian installer automatically installed Grub 2 to the EFI partition, when i manually issue grub-install to the HFS+ partition, grub-install fails. I'm a bit in the dark about how Fedora/Ubuntu solves this problem, those distributions create a HFS+ partition and get it to boot after the install.

I'd like to avoid using refind because i'm not using OS X anymore. I do however have OS X installed on a SD card.

How can i get my laptop to boot Debian directly without using refind?

  • 2
    Apple should support a FAT32 /boot/efi partition as it's mandatory according to the spec. The spec doesn't ban the use of any other filesystem which is why Apple use HFS+. Anyway, can you expand your post with the error message from grub-install? – garethTheRed Aug 13 '14 at 7:15
  • Inspired by your comment i reinstalled debian without a HFS+ partition with just a fat32 EFI partition. After a normal install and then using OS X recovery to bless the grubx64.efi file it worked. weird that it didn't the last time. still, thanks for your help. – Peter Verbrugge Aug 14 '14 at 6:26
0

Would you mind expanding on how you "using OS X recovery to bless the grubx64.efi file"?

I booted from an OS X installation SD card, started a terminal but was not able to mount the fat32 EFI partition. I tried mount -t exfat /dev/disk1s1 /Volumes/xxx but it came back saying "Invalid argument". I also tried -t msdos to no avail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.