4

Ok. I am literally installing it from scratch and tracking my process here and now. I've been fighting this for so long.

Macbook Pro, 2008 I believe. ~200GB HD. I'm not dual booting. Mint and only Mint.

Linux Mint 17 Cinnamon x64 w/ Codecs. In order to boot from USB, I have to edit boot options to include nomodeset. I get live desktop up and running. Looks normal.

Double click "Install Linux Mint" > "Erase disk and install Linux Mint" (no encryption, no LVM) > "Require Password to Login" (yes Encrypt home folder). Installer finishes without problem. I don't reboot yet.

Still on the Live Desktop from the USB, since the laptop uses EFI, I know I need to install efibootmgr. sudo apt-get install efibootmgr. Success. Running sudo efibootmgr prints out

BootCurrent: 0000
BootOrder: 0000,0000,0000,0000,0000,0000,0000,0000,0000
Boot0000* ubuntu
BootFFFF*

sudo poweroff, pull out USB, boot holding F6 to get efibootmgr's boot menu. I haven't touched nvidia drivers yet, so I still need to add nomodeset to the boot script. Not setting nomodeset will get me to a black screen and nothing ever happens.

Booting from the HD and the display is off a little. The Mint splash icon is off center, there's a 1/4 to 1/2 inch gap at the top of the screen where the mouse can't go and nothing is drawn (it's solid black) and the screen generally thinks that it is bigger than it really is. After signing in, the task bar is off the bottom of the screen and there's a couple inches of missing screen off the right hand side as well. Everything else seems to function fine, no discoloration.

Need an internet connection. I guess my way to the menu button and click on System Settings > Device Drivers. I insert my USB drive that I previously booted from. I go down to broadcom and click bcmwl-kernel-source then Apply Changes. Remove USB. Shutdown, and start back up holding F6 (still need nomodeset).

Screen is still oversized and off center. I connect to my home network and successfully ping 8.8.8.8. On a different computer, I pull up this forum post and run:

sudo add-apt-repository -y ppa:ubuntu-x-swat/x-updates && sudo apt-get -y update && sudo apt-get -y install nvidia-current nvidia-settings

It finishes successfully. During previous trials, I found that I need an xorg.conf for xserver to start. So I run sudo nvidia-xconfig and then sudo reboot hoping it works.

No F6 this time. I shouldn't have to. Now here's the problem I can't fix. After the linux splash, I get the blue background old school dialog saying "Failed to start the X server." The short version of the log is

NVIDIA: could not open the device file /dev/nvidia0 (Input/output error)
no screens found

I can login to a tty console after getting through the blue dialog and I pushed the long version of the log to my other computer's ftp. Maybe it can shed some light. Oh, and /dev/nvidia0 does exist.

I have tried setting the BusID to PCI:1:0:0 in xorg.conf as some people have claimed that fixed it for them, but not for me. Running lspci | grep VGA lists that my graphics card is NVIDIA Corporation G84M [GeForce 8600M] (rev a1). I've tried running without an xorg.conf, I still get the same error. Running 'sudo startx' is no different.

I'm officially out of ideas. If I didn't mention anything above, then I left it at it's default value. I've spent dozens of hours and learned a lot as I've gone, but I'm at my wit's end. Any clue what to try next?

EDIT: Here's my xorg.conf generated by sudo nvidia-xconfig when I have nvidia-331 drivers installed.

  • Can you please paste the output of **lspci -v | grep -i vga"? – tink Aug 13 '14 at 2:54
  • 01:00.0 VGA compatible controller: NVIDIA Corporation G84M [GeForce 8600M GT] (rev a1) (prog-if 00 [VGA controller]) – Corey Ogburn Aug 13 '14 at 2:58
  • Your Xorg.0.log says to look in the kernel log for nvidia related messages: "Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please [...] kernel log [...] refer to Chapter 8: Common Problems in the README [...]". – András Korn Sep 8 '14 at 6:24
0

If it helps anybody, I did manage to install the nVidia drivers using nomodeset at first, and then trying several drivers to see which one would stick.

My macbook pro 2008 has an nVidia GTM 8600. The driver I used was nvidia-173. You can select this from Administration -> Driver Manager.

Each time a driver failed I would be pushed to the terminal. From there I would remove the drivers that didn't work and then try again.

Here's a great answer on how to remove nVidia drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.