3

This is something that has been bugging me for awhile and I haven't been able to find a fix yet. Whenever I change the system volume using the hardware volume keys on my laptop, it also changes the Spotify volume (it moves the Spotify volume slider as well as the system volume slider). Is there a way to prevent this from occurring? I've searched around for awhile and haven't found anything.

I have looked at Arch's awesome wiki, but I haven't found anything that helped the problem. A similar issue is described here on the wiki, but it didn't solve the problem.

This issue has occurred on all the desktop environments I've used on Arch so far. XFCE, Gnome, and Cinnamon (what I'm currently using) all suffer from this. I believe I am using pulseaudio for my audio server. I am also using the Linux Preview of Spotify which I installed from the AUR.

If someone posts a solution that works, I will be sure to add it to the Arch Wiki for others to reference.

  • Could it be that they both are simply the same volume setting... – HBruijn Aug 12 '14 at 20:33
  • @HBruijn Well it treats them as the same volume setting, but this is not how it works in Ubuntu, for example. In Ubuntu the sound setting for Spotify and the system volume are separate, meaning the Spotify volume does not change when hardware volume buttons are pressed. It also does not work this way in Windows. From my experience Arch acts differently with regards to Spotify volume compared to every other distro/OS I've used. – Matthieu Aug 12 '14 at 21:10
4

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Per-application_volumes_change_when_the_Master_volume_is_adjusted

It's a pulseaudio default setting to link all the volumes together. Setting

flat-volumes = no

in /etc/pulse/daemon.conf should fix that!

  • Also worth noting that the man page suggests that ~/.config/pulse/daemon.conf should also work. – Charles Jul 18 '16 at 7:18
  • I already had this option set to no, but Spotify's volume and the system volume keep getting synchronized. Is there another place where this setting might be set to yes? Is there a command that I can use to see the effective settings? – Rapti Nov 7 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.