1

I have a Macbook Pro that I believe is from 2008. It's harddrive is completely wiped and formatted (FAT32 if I remember correctly) with the only exception of a working installation of rEFIt. Not even an OS. I want to install Linux Mint 17 x64 on it. I've burned two DVDs from the ISO and neither are recognized as bootable media (the CD is spit out every time I try to boot from it). I have two different thumb drives I've been alternating between. They're 16GB and 8GB and I haven't noticed any difference between them. They both seem fully functional. I've spent 20+ hours on this over the weekend and here's what I see and what I know so far.

I've tried both USB Universal Installer (UUI) and UNetbootin to image the thumb drives. I've given up on UNetbootin after hearing a few negative things, besides, it didn't work for me. When I plug the UUI drive in, rEFIt adds 3 options: boot with /efi/boot/bootx64.efi, boot with /efi/boot/grubx64.efi, or the generically title "Boot Linux from UUI".

If I "Boot Linux from UUI" the screen goes black except for the words "Missing Operating System." I've tried reformatting the thumb drive (a full reformat, not a "quick" one) before reimaging but I get the same error anyway.

As for the other two options, they both do the same thing. They present with 3 options (in a black and white terminal style UI). I don't remember the wording exactly but it basically boiled down to "Boot Linux Mint", "Boot Linux Mint (Compatibility Mode)", and "Check storage medium integrity".

Selecting "Boot Linux Mint" leads to a never ending black screen. No output, no splash, just an "on" black (there's power to the screen, it didn't turn it off). I've let it sit for 5 or 10 mins with no change.

Selecting "Boot Linux Mint (Compatibility Mode)" gets me some output. I'm rather new to linux so I don't recognize much of the output. It looks like some of the normal output from a linux boot. If I understand correctly, the number in brackets at the left hand side of each line of the output is uptime in seconds. This output will go for about 6 seconds before stopping (not always at the same line) and seems to freeze. No blinking cursor, no progress. I've also let this sit for 5 or 10 mins and it never moves on.

"Check storage medium integrity" sits at a black screen similar to "Boot Linux Mint".

I've tried installing x86 instead of x64, I've tried Mate instead of Cinnamon (didn't have much hope for that one, but I'm desperate), I've tried both USB slots in the laptop. I've tried editing the boot statements and did notice that one of the paths started with /cdrom/... but changing it to usb or blk3 (I've learned in the EFI shell that the USB could be accessed by blk3:) had no visiable change. I haven't tried a different Linux because I'm really pulling for Mint. What experience I have from trying Linux in VMs is mostly Mint. Installing Ubuntu isn't my end game, but if you'd think it'd help, I'm willing to try it. If I did get Ubuntu installed, I wouldn't know what to do next.

For me, it simply isn't as easy as this page makes it sound. I'm learning quite a bit though, and honestly part of me loves it. However it's been long enough. I just want the problem solved. What can I do to help make this installation happen?

1

Try again and at the point where you are about to choose Boot Linux Mint press the e key

Use the cursor keys to move up and down and find the line that begins linux /vmlinux...

Append nomodeset to the end of the line and press Ctl+X to start with this new option.

When (If?) you manage to boot, you'll need to figure out what video card your Macbook uses and install the relevant driver. I believe it's an Nvidia on yours, but as I don't have an Apple device, I can't confirm this.

  • As soon as I get home from work, I'll try this. I do know it has an NVidia GPU. This sounds like a good reason for it to freeze (at least visually). – Corey Ogburn Aug 11 '14 at 20:36
  • Splash... Cursor... DESKTOP! Success (so far) – Corey Ogburn Aug 11 '14 at 23:20
  • This leads to the next natural question. Will the installed OS start in software mode? Can I install video drivers from the live desktop? How? – Corey Ogburn Aug 11 '14 at 23:34
  • Yep. Successfully installed (I think) won't boot because I can't set nomodeset. I'm using efibootmgr so adjusting grub settings don't change anything. I don't know how to tell efibootmgr to set nomodeset. – Corey Ogburn Aug 12 '14 at 0:56
  • Are you certain that you're booting directly from UEFI? Press the Shift key as soon as you've selected an entry in the boot manager entry to see if grub appears again. – garethTheRed Aug 12 '14 at 5:25
1

I have a Macbook 2006 running linux mint 17. The only thing you should do is start 32bit linux mint live CD and from the installation manager to delete all partitions you have on your macbook and create a new partition to install linux. Then reboot and install linux mint normally.

-1

from my experience​ , burn the iso 64 or 32bit slow up to 8x max with imgburn , insert the disc in Mac slot and when u hold down command and see refit , refresh by hitting escape key and then u will see like a windows icon which will say boot in legacy mode , then Linux will initiate and don't touch , just let it auto run and install and then u can proceed further.

  • I'm glad that worked for you. If you actually read the question though you'll see I tried that and it doesn't work. – Corey Ogburn Jun 5 '17 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.