1

I need to move a 16 GB folder to my external drive, but moving it manually gives me an in use error. I have tried to start in safe mode and moved it but it was still in use.

I have run these commands

diskutil repairdisk /dev/disk0s2
diskutil repairdisk /dev/disk2

Where disk0 is my disk and disk2 is the one I want to move it to.

I have no permission errors and I have even run sudo mv -f it gives me these:

mv: symlink: ../../../../../Preferences/com.apple.systemsound.plist: File exists`

I have also gotten the same error but without symlink

For 200 files and the last error is this

mv: /bin/cp: terminated with 1 (non-zero) status

What can I do? I have also ran sudo chmod 777 for both folders and used the "include for all files option (OS X).

By request here is the exact command:

sudo mv -f ~/desktop/collections/jadd /Volumes/External\ 4 
  • Are any of the files over 4gb? What file system is the destination disk? – rob Aug 11 '14 at 13:26
  • Its a "Mac OS Extended (journaled)" and the biggest file is 1,58 GB – DisplayName Aug 11 '14 at 13:30
  • Please edit your question and show us the exact command you used and the exact error received. – terdon Aug 11 '14 at 13:31
  • But the error is over 200 lines? – DisplayName Aug 11 '14 at 13:32
  • Is /Volumes/External\ 4 empty or does it have files (possibly duplicates of what you're trying to move) in it already? – Mark Plotnick Aug 11 '14 at 13:46
0

Can't you do it from Finder? Also please make sure the external drive is really OSX Extended Journal. It appears it is either NTFS or FAT32.

  • I already said i did it via Finder, and i have never had a windows computer or anything else so there is no reason to have a NTFS or FAT32 disk. – DisplayName Aug 11 '14 at 14:03
  • Read your post again and point me where you mentioned about Finder. And remove your down vote if you have not mentioned indeed. – antimatter Aug 11 '14 at 14:11
  • I didnt mention "Finder" but here, In the beginning, "but moving it MANUALLY gives me an in use error. I have tried to start in safe mode and moved it but it was still in use. ". Which means via the Finder and not command-line. – DisplayName Aug 11 '14 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.