0

I am running Ubuntu 12.04 LTS. I installed the i3 window manager and have become pretty comfortable with it.

And yesterday, When I tried to use Lampp for web dev, it didn't work. The window manager was the last thing on my mind, and thus I created a new file and tried to access it, but nothing really worked.

Then, as a longshot, I logged out and logged in again into a Gnome session, and it worked!

Thus, lampp is not working with the i3 window manager.

I got the error ERR_EMPTY_RESPONSE when I tried to access a project stored in the directory /opt/lampp/htdocs/ (just to give background, I am a power user and have used Lampp for a long time now and have never faced this problem, and it's not a problem with the setup, as I have already checked all the settings and the exact settings are working in the Gnome session).

The following commands are the ones that I used.

  1. sudo /opt/lampp/lampp start

  2. sudo chmod 777 -R /opt/lampp/htdocs/ (Ensuring that access denied error is not thrown by the browser)

  • This software. I'm no web developer or anything but I've installed the 64bit v. vanilla + security script, and loaded the default welcome page(with status) in the browser with the demos. I'm on Arch though but I use i3. Could you provide more detail into what I could try out to reproduce your issue? – user44370 Aug 11 '14 at 13:47
  • @Learn Please use code formatting only for code, not to emphasize random words. – Gilles Aug 11 '14 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.