6

In LXDE, the task bar shows tabs for all currently running applications/windows, as shown on the screenshot below:

enter image description here

The problem is, I have hard time distinguishing which window is the one I am in right now (active window)

All tabs look the same to me. Is there any way to configure active window to have another color ?

2

I had similar issue in LXDE. After some investigation, I found out that this setting comes from gtk theme.

Go to your gtk theme, ie

/usr/share/themes/<your_theme_name>/gtk-2.0/gtkrc

And find the "button" section. Add the following bg[ACTIVE] line:

style "button" {
....
bg[ACTIVE]        = shade (0.55, "#804c44")
...
}

adjust the color code #804c44 as appropriate.

4
+100

There is no option to change the appearance for the active window in lxpanel's Task Bar (Window List) plugin. You can patch the lxpanel source file launchtaskbar.c in the most recent version, LX Panel 0.7.1. - LXDE - Lightweight X Desktop Environment - Browse /LXPanel (desktop panel) at SourceForge.net

For example, you could make the active window use bold font while using the flat button style:

Find line 1589 of launchtaskbar.c which reads:
gboolean bold_style = (((tk->entered_state) || (tk->flash_state)) && (tk->tb->flat_button));

Replace with:
gboolean bold_style = (((tk->entered_state) || (tk->flash_state) || (tk->focused)) && (tk->tb->flat_button));

The only change is that tk->focused was added to bold_style to check if the window for that item is focused.

Ultimately, it require some knowledge of coding in C to add custom functionality to the appearance. If you're not familiar with patching, research the topics HowTo Apply a Patch File To My Linux / UNIX Source Code and How to Compile and Install Software from Source Code on Linux.


The above example is from the following patch which appears to be outdated since it targets the file name taskbar.c instead of launchtaskbar.c. - LXDE - Lightweight X Desktop Environment / Feature Requests / #213 [lxpanel][taskbar] highlight active task with flat buttons

Update: I compiled a patched source with the above code on lxpanel-0.6.1 and it was glitchy. It kept reloading lxpanel. You might try an SE network that's more oriented toward coding to figure out how to customize it this way.

1

You could try playing with the options available when you right click on the panel and select Panel Settings from the context menu. When the Panel Preferences window opens, click on the Panel Applets tab. Find and click on the Task Bar (Window List) line. Then click on the Edit button on the right side of the window.

                           ss#1

References

  • thanks for the tip, but unfortunately there does not seem to be any settings relevant to my issue. – Martin Vegter Oct 22 '14 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.