28

I have two monitors:

------   ------
|VGA-1| |HDMI-1|
------  --------

for some reason VGA-1 defaults to the primary monitor. Now this is what I have tried to fix this:

  1. Go to settings edit and set primary on HDMI-1 to True
  2. This: Fedora primary monitor selection
    Now it seems it did a trick since HDMI-1 is primary according to "xrandr --current". However the panel is still on the left (VGA-1) monitor and I'm not sure that my HDMI-1 is primary at all.

Is this a bug or I'm doing something wrong here?

2 Answers 2

36

Right click the panel, go to 'Panel preferences'. You'll have a dropdown for 'Output'. Change this from 'Automatic' to the display you want it to show up on. By default it will be on the left-most monitor.

xfce panel preferences

5
  • 1
    This works only for panel placement, not for primary display selection. Primary display is the display where were all the windows before the additional display was connected.
    – andrej
    Commented Oct 30, 2016 at 16:38
  • 1
    For me, windows pop up on whatever display the mouse cursor is on. I forget what controls this though.
    – phemmer
    Commented Apr 12, 2017 at 12:54
  • Popping up is not related to primary/secondary/tertiary display.
    – andrej
    Commented Apr 12, 2017 at 19:16
  • 1
    In fact this got worse when connecting third monitor (left is for VGA, middle is for notebook screen and right is for DisplayPort - the left/top display always grabs the Panel.
    – andrej
    Commented Apr 12, 2017 at 19:24
  • 2
    Changing this from Automatic to Primary works for me. In automatic mode it was on the primary screen with 2 screens attached, but when attaching the 3rd screen and changing settings on it, the bar jumped to the new (non-primary) screen. This is not the case when setting to Primary (which was my expected default behavior).
    – Lion
    Commented Sep 4, 2020 at 15:43
1

As mentioned in the comments to the @phemmer's solution, it only holds for enabling panel. Desktop icons, menu etc. would still be not visible.

To actually fix this, do:

  1. Right-click while in desktop and go to Applications > Settings > Display
  2. Then in Display settings choose the proper monitor and toggle it as a Primary Display as shown in the image below.

Display settings with Primary option toggled

After doing that, all desktop utilities should be visible and configuring panel to be shown in a primary display would work too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .