4

I recently got a new desktop, installed debian 64 bit, and found out that the sound doesn't work at all. I'm not entirely sure what information I should give to help identify the problem but I'll do my best...

The motherboard provides the sound, an Asus Z97 A, which has a Realtek ALC892 chip for sound.

I tried editting /etc/pulse/default.pa to add tsched=0. I also tried adding default-sampling-rate = 48000 to /etc/pulse/daemon.pa. And I also tried running as admin and adding myself to the audio group. None of that helped.

I also tried upgrading my kernel using wheezy backports from 3.2 to 3.14. It changed what weird sound I heard instead of the correct sound, but didn't actually help.

I also tried adding the line snd-hda-intel vid=8086 pid=8ca0 snoop=0 to /etc/modules and /etc/modprobe.d/fix-audio.pref (alternately, not both together).

Right now I'm running kernel version 3.12, because my video card driver doesn't support 3.14, and 3.2 spat out errors about the hda-codec on bootup. 3.12 got rid of the errors, but sound still doesn't play properly.

In BIOS I changed the frontport audio from hd audio to AC97. This made it so that I can actually hear the sound I'm playing, not just garbled junk, but it still crackles and echos. The sound is much better in chrome than in the default player for .mp3 files, which seems to simply be called movie player.

closed as off-topic by muru, cuonglm, X Tian, Anthon, Archemar Sep 30 '15 at 5:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – muru, cuonglm, X Tian, Anthon, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I have the exact same problem! – niklon Dec 10 '14 at 20:48
0

I had this problem on a program that I was using, to fix it I downloaded a new sound driver. There are a lot of drivers, I use ASIO4ALL v2 I like it but it is for a program and the program itself launches it. it isn't default, so make sure you set it up like you want it.

sorry if this doesn't help

  • I linked the driver, but seeing as this as a Linux Forum, and that's a Windows Driver, how does this help, i.e do you know of a Linux version? – eyoung100 Jul 6 '15 at 23:36
  • I do not. I have only done this for windows, but I thought it might help. if you google linux sound drivers maybe you can find something. – bofimpact Jul 6 '15 at 23:46
0

This was a problem on Debian Wheezy, when I upgraded to Jessie the issue went away.

Not the answer you're looking for? Browse other questions tagged or ask your own question.